]> sipb.mit.edu Git - ikiwiki.git/blobdiff - debian/rules
comments
[ikiwiki.git] / debian / rules
index da8249920a4daa0208c3e9cf7098ba7b1b5a00fa..28ac84d252555ce8a6e8f5a75d88f66671bdff58 100755 (executable)
@@ -1,13 +1,18 @@
 #!/usr/bin/make -f
+%:
+       dh $@
+
+override_dh_auto_configure:
+       # keeps it out of /usr/local
+       dh_auto_configure -- PREFIX=/usr
 
-binary: binary-indep
-binary-indep:
-       dh $@ --before dh_compress
+override_dh_compress:
+       # avoid compressing files in the doc wiki
        dh_compress -Xhtml
-       dh $@ --after dh_compress
 
-%:
-       dh $@
+override_dh_auto_clean:
+       # distclean moans about MANIFEST, this is quieter
+       $(MAKE) realclean
 
 # Not intended for use by anyone except the author.
 announcedir: