]> sipb.mit.edu Git - ikiwiki.git/blobdiff - debian/rules
(no commit message)
[ikiwiki.git] / debian / rules
index 115b3f0c20fae4ecd26c9747d8f9790988a7d71b..0a65715214cf2464dc021bc820de3f5bf049a1f6 100755 (executable)
@@ -2,6 +2,18 @@
 %:
        dh $@
 
+# keeps it out if /usr/local
+override_dh_auto_configure:
+       dh_auto_configure -- PREFIX=/usr
+
+# avoid compressing files in the doc wiki
+override_dh_compress:
+       dh_compress -Xhtml
+
+# distclean moans about MANIFEST, this is quieter
+override_dh_auto_clean:
+       $(MAKE) realclean
+
 # Not intended for use by anyone except the author.
 announcedir:
        @echo ${HOME}/src/ikiwiki/doc/news