web commit by JeremyReed: fix link to SharedHosting by prefixing with slash.
[ikiwiki.git] / debian / NEWS
index 5515bbd7db9e4ba81c7e29effe6cd648fb9c5ae5..983d1ae9d969044a20d2c0dff0c3150d930ab17f 100644 (file)
@@ -1,3 +1,59 @@
+ikiwiki (2.40) unstable; urgency=low
+
+  ikiwiki now has an new syntax for preprocessor directives, using the
+  prefix '!':
+
+  [[!directive ...]]
+
+  This new syntax no longer relies on spaces to distinguish between
+  wikilinks and preprocessor directives.  Thus, wikilinks can use spaces
+  in their link text, and preprocessor directives without arguments (such
+  as "toc") need not use a trailing space.
+
+  To enable the new syntax, set prefix_directives to true in your ikiwiki
+  config.  For backward compatibility with existing wikis,
+  prefix_directives currently defaults to false.  In ikiwiki 3.0,
+  prefix_directives will default to true, and wikis which have not yet
+  converted to the new syntax will need to set prefix_directives to false
+  in their setup files.
+
+  To convert your wiki to the new syntax, ikiwiki provides a new script
+  ikiwiki-transition.  It will convert preprocessor directives in
+  all files given on the command line.  To convert an entire wiki:
+
+  find wikidir/ -type f -name '*.mdwn' -print0 | xargs -0 ikiwiki-transition prefix_directives
+
+  Even with prefix_directives disabled, ikiwiki now allows an optional '!'
+  prefix on preprocessor directives (but still requires a space).  Thus, a
+  directive which uses a '!' prefix and contains a space will work with
+  ikiwiki 2.40 and newer, regardless of the value of prefix_directives.
+  This allows the underlay to work with all ikiwikis.
+
+ -- Josh Triplett <josh@freedesktop.org>  Sat, 26 Jan 2008 16:26:47 -0800
+
+ikiwiki (2.30) unstable; urgency=low
+
+  Ever feel that ikiwiki's handling of RecentChanges wasn't truely in the
+  spirit of a wiki compiler? Well, that's changed. The RecentChanges page is
+  now a static page, not a CGI. Users can subscribe to its rss/atom feeds.
+  Custom RecentChanges pages can be easily set up that display only changes
+  to a subset of pages, or only changes by a subset of users.
+  
+  All wikis need to be rebuilt on upgrade to this version. If you listed your
+  wiki in /etc/ikiwiki/wikilist this will be done automatically when the
+  Debian package is upgraded. Or use ikiwiki-mass-rebuild to force a rebuild.
+
+  With this excellent new RecentChanges support, the mail notification system
+  is its age (and known to be variously buggy and underimplemented for
+  various VCSes), and so ikiwiki's support for sending commit mails is REMOVED
+  from this version. If you were subscribed to commit mails, you should be
+  able to accomplish the same thing by subscribing to a RecentChanges feed.
+
+  The "notify" field in setup files is no longer used, and
+  silently ignored. You may want to remove it from your setup file.
+
+ -- Joey Hess <joeyh@debian.org>  Tue, 29 Jan 2008 17:18:31 -0500
+
 ikiwiki (2.20) unstable; urgency=low
 
   The template plugin has begin to htmlize the variables passed to templates.