]> sipb.mit.edu Git - ikiwiki.git/blob - debian/changelog
post for Don
[ikiwiki.git] / debian / changelog
1 ikiwiki (1.27) UNRELEASED; urgency=low
2
3   * Add a googlecalendar plugin. A bit special-purpose, but it shows
4     one way to to deal with user-supplied content that could cause XSS
5     issues w/o the htmlscrubber, and won't survive the scrubber.
6   * Work on firming up the plugin interface:
7     - Plugins should not need to load IkiWiki::Render to get commonly
8       used functions, so moved some functions from there to IkiWiki.
9     - Picked out the set of functions and variables that most plugins
10       use, documented them, and made IkiWiki export them by default,
11       like a proper perl module should.
12     - Use the other functions at your own risk.
13     - This is not quite complete, I still have to decide whether to
14       export some other things.
15   * Changed all plugins included in ikiwiki to not use "IkiWiki::" when
16     referring to stuff now exported by the IkiWiki module.
17   * Add a module version number to IkiWiki, so you can "use IkiWiki '1.00'"
18     to declare which version of the interface your plugin needs.
19   * Anyone with a third-party ikiwiki plugin is strongly encouraged
20     to make like changes to it and avoid use of non-exported symboles from
21     "IkiWiki::".
22   * Link debian/changelog and debian/news to NEWS and CHANGELOG.
23   * Support hyperestradier version 1.4.2, which adds a new required phraseform
24     setting.
25   * If an inlined page has a permalink, link the page title to that.
26   * Patch from Recai to use utf8 when reading the setup file, so that
27     utf8 wikinames from there will be used properly.
28   * Patch from Recai to kill utf-8 on the wiki name when generating the
29     session cookie.
30   * Change ddate plugin to use the DateTime::Calendar::Discordian perl module.
31   * Fix a baseurl problem in hyperestradier search results.
32   * Add a stub local.css to avoid problems with 404's.
33   * Patch from Recai to fix a wide character warning from the search plugin
34     during setup if the wikiname contains utf8.
35   * Yet another fix for those poor case-insensative OSX users.
36   * pagetemplate hooks are now also called when generating cgi pages.
37   * Add a favicon plugin, which simply adds a link tag for an icon to each
38     page (and cgis).
39   * Patch from James Westby to deal with the case where you're editing a
40     new page, hit cancel, and need to be redirected to somewhere sane.
41   * Various documentation improvements by various wiki users.
42   * Support Text::Markdown from CPAN, which has a different interface from
43     the original markdown or the one in Debian.
44   * Version the libcgi-session-perl dependency, some features that need
45     the new version are used in some cases (sslcookie).
46
47  -- Joey Hess <joeyh@debian.org>  Fri, 15 Sep 2006 22:28:31 -0400
48
49 ikiwiki (1.26) unstable; urgency=low
50
51   * Add a missing -n to tla undo call.
52   * otl2hmtl can't be safely used with IPC::Open2 since it sometimes
53     writes before consuming its whole stdin. Avoid this deadlock.
54   * Fix alt tags for outline checkboxes.
55
56  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 16:24:16 -0400
57
58 ikiwiki (1.25) unstable; urgency=low
59
60   * Add proper waitpid calls for open2ed processes throughout to avoid
61     zombies; this hit htmltidy especially badly.
62   * Drop real uid/gid in the suid wrapper, thus allowing commits to remote
63     subversion repos and fixing some other issues.
64   * Add support for tla, contributed by Clint Adams. Closes: #385936
65   * Add support for mercurial, contributed by Emanuele Aina.
66   * Include <link rel> tag for RSS feeds, used by some aggregators and
67     firefox to find the feed.
68   * Add a linkmap plugin (requires graphviz).
69
70  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 01:54:14 -0400
71
72 ikiwiki (1.24) unstable; urgency=low
73
74   * Simplify the data structure returned by rcs_recentchanges to avoid
75     each rcs plugin needing to form complex strings on its own.
76   * Fix another destpage issue in the inline directive. Closes: #385512
77     again.
78
79  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 15:46:45 -0400
80
81 ikiwiki (1.23) unstable; urgency=low
82
83   * Allow inline directives to be nested inside eg, sidebars. Closes: #385512
84
85  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 12:14:45 -0400
86
87 ikiwiki (1.22) unstable; urgency=low
88
89   * Change how the stylesheet url is determined in the templates: Remove
90     STYLEURL and add BASEURL to all templates (some already had it). This
91     new more general variable can be used to link to other things (eg, images)
92     from the template, as well as stylesheets.
93   * Fix a bug introduced last version to do with nested inlines.
94   * Allow preprocessor directives to span multiple lines, both to make
95     long ones with lots of values easier to write, and to allow for ones with
96     multi-line quoted values.
97   * Allow preprocessor directives to contain python-like triple-quoted
98     text blocks, for easy nesting of quotes inside.
99   * Add a template plugin.
100   * Make pagespec merge code smarter about merging duplicate pagespecs.
101   * Patch from Jordà Polo to make Setup::Standard support hashes in config
102     files.
103   * Change order of linkify and preprocess; first preprocess and then linkify.
104     This allows passing a wikilink inside a parameter to a preprocessor
105     directive without it being expanded to html, and leaking out of the
106     parameter, which had required some non-obvious use of triple-quoting
107     to avoid. Note that any preprocessor plugins that output something
108     that looks like a wikilink will now have it treated as such; AFAIK
109     this doesn't change any behavior though except for the template plugin.
110   * Enable preprocessor directives when previewing an edit.
111   * Make all pages pull in a local.css style sheet, if present. This won't
112     be included in ikiwiki, but can be created to make local styling changes
113     w/o needing to merge in every new change to the distributed style.css.
114   * Use DESTDIR and not PREFIX to specify installation prefix for packaging.
115   * Support running "perl Makefile.PL PREFIX=foo" to build ikiwiki to run
116     from a different directory.
117   * Generalised preprocesser loop protection code.
118   * Patch from James Westby to allow a description to be set for rss feeds.
119   * Patch from James Westby to add a template for the search form.
120   * Added a ddate plugin.
121   * Patch from James Westby to add a --sslcookie switch, which forces
122     cookies to only be sent over ssl connections to avoid interception.
123   * Fix preferences page on anonok wikis; still need to sign in to get
124     to the preferences page.
125   * Add toc (table of contents) plugin.
126   * Change htmlize, format, and sanitize hooks to use named parameters.
127   * Patch from James Westby to add an actions option to inline; this
128     adds Edit and Discussion links at the end of blog entries.
129   * Due to some css changes, you'll want to rebuild your wiki on upgrade
130     to this version. Will be handled automatically by the deb.
131   * Add processed date to aggregate preprocessor directive status output.
132
133  -- Joey Hess <joeyh@debian.org>  Fri,  1 Sep 2006 22:03:34 -0400
134
135 ikiwiki (1.21) unstable; urgency=low
136
137   * Add a tail fin^W^Wsidebar plugin by Tuomo Valkonen.
138   * If a page links to itself, mark up the link text in a span with
139     class="selflink" so that it can be styled. I don't have a useful style
140     defined for that though.
141   * Call filter hooks on inlined page content.
142   * Support inlining pages raw, rather than creating a blog.
143   * Clean up yes/no parameter parsing in inline plugin.
144   * Implemented better cycle detection in the inline plugin; nested inlines
145     will now work.
146   * Add a map plugin contributed by Alessandro Dotti Contra.
147   * Add otl format plugin, which handles files as created by vimoutliner.
148   * Fix ikiwiki-mass-rebuild to work in the way the postinst uses it.
149   * Add first draft at a Restructured Text (rst) plugin, by Sergio
150     Talens-Oliag. Note that this has many known issues -- see the caveats on
151     the plugin's page.
152   * Credit everyone who wrote a plugin on the plugins' wiki pages.
153   * Fix utf-8 in blog post form.
154
155  -- Joey Hess <joeyh@debian.org>  Sun, 20 Aug 2006 16:42:54 -0400
156
157 ikiwiki (1.20) unstable; urgency=low
158
159   * Relicense the templates and basewiki under the 2-clause BSD license.
160     Since these can easily become part of other people's websites, they
161     should be under as permissive a license as possible.
162   * Add --syslog config option, to log to the syslog.
163   * Catch failing IPC::Open2 in tidy plugin and retry in case this is a
164     transient failure to fork (which I've seen happen in the wild).
165   * Fix a bug in the aggregator introduced last version that caused all
166     aggregator state to be lost during a non-aggregating build.
167
168  -- Joey Hess <joeyh@debian.org>  Thu, 17 Aug 2006 19:05:56 -0400
169
170 ikiwiki (1.19) unstable; urgency=low
171
172   * Fix several related bugs in page type determination during online editing.
173   * Add some locking to prevent 2 aggregators from running at once.
174   * Fix an infinite loop in the aggregator when finding a unique filename.
175
176  -- Joey Hess <joeyh@debian.org>  Wed, 16 Aug 2006 13:46:25 -0400
177
178 ikiwiki (1.18) unstable; urgency=low
179
180   * The last release accidentially installed ikiwiki as ikiwiki.pl, now fixed.
181   * Add --version.
182   * Man page format fixups.
183   * If the meta plugin overides the page title, set a title_overridden
184     variable in the template to true. This allows doing things with the
185     templates conditional on the title being overriden.
186   * Add a %pagecase which maps lower-case page names to the actual case
187     used in the filename. Use this in bestlinks calculation instead of
188     forcing the link to lowercase.
189   * Also use %pagecase in various other places that want to check if a page
190     with a given name exists.
191   * This means that links to pages with mixed case names will now work,
192     even if the link is in some other case mixture, and mixed case pages
193     should be fully supported throughout ikiwiki.
194   * Recommend rebuilding wikis on upgrade to this version.
195
196  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 22:10:48 -0400
197
198 ikiwiki (1.17) unstable; urgency=low
199
200   * Disable tidy generator tag.
201   * Move tidy back to sanitize hook, found out how to only show body.
202   * Turn off tidy indentation too.
203   * Turn on HTML::Template loop_context_vars; not actually used in stock
204     templates but can be useful for things like making comma-delimited lists
205     of tags or what have you.
206   * Remove <br> from end of aggregate preprocessor directive output.
207   * Ship ikiwiki executable as ikiwiki.pl in source to avoid issues on
208     case-sensative filesystems like OSX.
209   * Improve markdown loading. First, try to load it as a proper perl module,
210     in case it was installed as one. Then fall back to trying
211     /usr/bin/markdown.
212   * Document in install page how to install markdown, since it has no
213     installation procedure in the upstream tarball.
214   * Set die_on_bad_params => 0 for all templates, to allow users to modify
215     them without annoyances.
216   * Suck in the page content when generating an inline archive page, to work
217     around the meta plugin's lack of caching of title metadata across runs.
218
219  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 12:52:13 -0400
220
221 ikiwiki (1.16) unstable; urgency=low
222
223   * Try to handle relative links in aggregated feeds. However,
224     the current support is a crude hack due to limitations of XML::Feed:
225     xml:base is not supported, neither is Content-Location. And of course,
226     relative links in RSS feeds are ill-undefined..
227   * Make aggregator save permalinks and author name to pages as metadata.
228   * Add permalink and author support to meta plugin, affecting RSS feeds
229     and blog pages.
230   * Various CSS and formatting changes.
231   * Encode link and guid urls in rss feeds to avoid illegal utf8 slipping in.
232   * Add xhtml files to the default prune regexp.
233   * Also generate rel=bookmark links for permalinks.
234   * Fix the htmltidy plugin, which wasn't working due my breaking it when
235     I added it..
236   * Don't run tidy with -xml as that fails if the input is not well-formed.
237     Run it with -asxhtml instead, so it will output well-formed xhtml no
238     matter what the input.
239   * Disable tidy warnings too.
240   * Add a new format hook, and make tidy use it, since tidy can really only
241     operate on and output complete html documents, not the body chunks
242     that sanitise gets.
243   * Fix dates in rss feeds if running localised, so they're still rfc 822.
244
245  -- Joey Hess <joeyh@debian.org>  Fri,  4 Aug 2006 20:48:36 -0400
246
247 ikiwiki (1.15) unstable; urgency=low
248
249   * Remove CDPATH and other env vars perl taint checking doesn't like.
250     Closes: #381279
251   * Added created_before and created_after PageSpec limits.
252
253  -- Joey Hess <joeyh@debian.org>  Thu,  3 Aug 2006 13:00:57 -0400
254
255 ikiwiki (1.14) unstable; urgency=low
256
257   * Memoize pagespec translation, this speeds up a build of the ikiwiki tree
258     by 10% or so.
259   * Fix stupid bug in date matching, patch from Roland Mas. Closes: #381132
260   * Added many unit tests for pagespec_match.
261
262  -- Joey Hess <joeyh@debian.org>  Wed,  2 Aug 2006 11:34:06 -0400
263
264 ikiwiki (1.13) unstable; urgency=low
265
266   * ikiwiki can now download and aggregate feeds with its new aggregate
267     plugin, so it's possible to implement a Planet using ikiwiki!
268   * Add a run_hooks function for the common task of running all hooks of a
269     given type.
270   * Add a savestate hook.
271   * Don't put blog post forms on pages if there's no cgiurl set.
272   * --setup --refresh no longer rebuilds wrappers. Use --setup --refresh
273     --wrappers to do that.
274   * Add %IkiWiki::forcerebuild to provide a way for plugins like aggregate
275     to update pages that haven't changed on disk.
276   * Change meta tags to use html entity-escaped text for values, so that
277     quotes and such can be represented in title tags.
278   * Depend and build-depend on HTML::Parser for HTML::Entities which is used
279     for the above.
280   * Make --rebuild also cause --aggregate to re-download and write aggregated
281     pages.
282   * Avoid outputting duplicate meta info.
283   * Include title metadata on aggregated posts for capitalised and un-munged
284     titles.
285   * Title metadata of inlined pages now shows up in blogs and rss feeds.
286   * Fix issue with unicode filenames and updating the hyper estradier search
287     index. (Aka Please Please Please, let that be the last one.)
288   * Patch from Roland Mas to support an rss=no parameter to inline directives.
289     Closes: #380743
290   * Renamed GlobLists to PageSpecs.
291   * PageSpecs can now include nested parens, "and", and "or". This remains
292     backwards compatible to the old GlobList format. It's implemented by
293     treating the GlobList as a very limited microlanguage that is transformed
294     to perl code that does the matching.
295   * The old GlobList format is deprecated, and I encourage users to switch to
296     using the new PageSpec format. Compatability with the old format will be
297     removed at some point, possibly by 2.0.
298   * Wiki rebuild needed on upgrade to this version due to PageSpec change.
299   * Add support for creation_month and creation_year to PageSpec.
300     Closes: #380680
301   * Changes to index file encoding.
302
303  -- Joey Hess <joeyh@debian.org>  Tue,  1 Aug 2006 21:21:19 -0400
304
305 ikiwiki (1.12) unstable; urgency=low
306
307   "Viva l'Italia!"
308   * New pagestats plugin from Enrico, which can generate a table counting
309     the backlinks for each page, or a del.icio.us style cloud.
310   * Build-depend on libtext-wikiformat-perl, so that the syntax check of
311     the wikiformat plugin works. Thanks, Emanuele Aina.
312   * Patch from Alessandro Dotti Contra to clean up backlinks and navbar
313     display, running them through pagetitle. This removes ugly underscores and
314     other gunk from the display, much nicer. You may want to rebuild your wiki
315     when upgrading to get the cleanup globally.
316   * Polygen plugin from Enrico.
317   * htmltidy plugin from Faidon.
318   * Locale patch from Faidon:
319     - Adds a locale setting to setup files.
320     - Proper local time, if the locale configuration option is used.
321     - Support for UTF-8 (or ISO-8859-X) filenames in SVN. Before this patch,
322       commiting (or even rcs_updating) on repositories with UTF-8 filenames was
323       impossible.
324   * Add getopt hook type, this allows plugins to add new command-line options.
325   * Add --tagbase option to tag plugin.
326   * Add exclude option in setup files, works same as --exclude.
327   * Put categories in rss feeds for tagged items.
328   * Allow preprocessor directives to be expanded in inlined blog pages.
329     However, to avoid inlining loops etc, don't expand inline directives in
330     inlined pages.
331   * fortune plugin (trivial)
332   * Tag plugins according to type.
333
334  -- Joey Hess <joeyh@debian.org>  Sat, 29 Jul 2006 17:12:56 -0400
335
336 ikiwiki (1.11) unstable; urgency=low
337
338   * Patch from Enrico that
339     - Adds a tag plugin that allows more easily tagging pages.
340       The meta plugin can also still be used for that, but the tag plugin
341       also lists a page's tags at the bottom of the page.
342     - Allows preprocessor directives to have parameters with no specified
343       value.
344     - Fixes preprocessor directive parameter parsing so that
345       foo=bar baz now means "foo=bar" and a "baz" with no value.
346   * Run pagetemplate hooks when inlining pages so that inlined pages also
347     list their tags.
348   * Make all plugins with pagetemplate hooks check that variables exist
349     on the template before setting them, for robustness.
350   * Switch pagetemplate hooks to using named parameters.
351   * Pass a destpage parameter to preprocessor and pagetemplate hooks.
352     This will be the page that a source page will be part of, which is
353     different than the source page for inlined pages.
354   * Audited all plugins to endure they pass (page, destpage) to htmllink
355     appropriatly. This means inlining of various plugins will not work
356     properly, with correct links generated.
357
358  -- Joey Hess <joeyh@debian.org>  Thu, 27 Jul 2006 20:51:23 -0400
359
360 ikiwiki (1.10) unstable; urgency=low
361
362   * Run page through any relevant filters when generating a page preview.
363   * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
364     default throughout the wiki, not only on wikitext pages. Decided to call
365     this a feature, and split the camelcase support out into a separate plugin
366     that is independant of wikitext.
367   * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
368
369  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 18:06:35 -0400
370
371 ikiwiki (1.9) unstable; urgency=low
372
373   * Improve display of parentlinks and page title of toplevel index page.
374   * Patch from Faidon to use svn --limit when possible for recentchanges,
375     speeds up recentchanges a lot for wikis with more history.
376   * Patch from Recai to fix utf8 issues in git backend.
377   * Add wikitext markup plugin, which supports ".wiki" pages written in the
378     original wiki syntax, CamelCase links and all.
379   * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
380     support, to edit pages etc without a web server.
381   * Display CGI processing errors if present.
382   * Fix from Faidon for a XML parser issue that breaks utf-8 for
383     RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
384     area, and also way slow.
385   * Match 'web commit from' in SVN and git, these are web commits too.
386     (Faidon)
387   * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
388     readable and avoid future mistakes. The patch seems to work and for the
389     first time I have a UTF-8 username ;-) (Faidon)
390   * Use form->field consistently, not form->param.
391   * Patch from Recai to allow selection of page type when creating a new page.
392     Default page type is inherited from the link clicked on to create the new
393     page.
394
395  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 17:25:30 -0400
396
397 ikiwiki (1.8) unstable; urgency=low
398
399   * Fix orphans plugin to not count a link to a nonexistant page as a reason
400     for a page not being an orphan.
401   * Support pinging services such as Technorati using XML-RPC to notify them
402     about changes to rss feeds.
403   * Parse svn log as xml for improved utf8 and security. Note that this makes
404     ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
405   * POSIX::strftime doesn't know about encodings and doesn't return a utf8
406     flagged string even if the locale causes it to generate utf8 output,
407     so make sure to let perl know it should be handled as utf8. Also,
408     the optimised version used for standard time formats won't work if the
409     user has changed locale, so drop it. Thanks, Faidon Liambotis.
410   * Fix re-encoding of the comments field to utf8 if a commit fails
411     due to a conflict. Thanks, Faidon Liambotis.
412   * Let svn know that commits have utf8 commit messages. Thanks, Faidon
413     Liambotis.
414   * Add insane double encode/decode to utf8 around call to markdown.
415     This works around a truely strange bug, which is apparently a bug in
416     perl, #376329. Also added a test case for it.
417   * Improve layout of edit page so formatting help link is always visible w/o
418     getting in the way of the preview.
419   * Centralised all calls to HTML::Template and force all the templates
420     to be read as utf8.
421   * Support pages with utf8 filenames. Patch by Faidon Liambotis.
422   * Introduce add_plugins and disable_plugins config options in setup files.
423     This allows adding or removing plugins w/o overriding the whole list of
424     default plugins, which makes it easier to upgrade when new default plugins
425     are added.
426   * Support htmlize plugins and make mdwn one such plugin, which is enabled by
427     default (of course!). Based on a patch by Faidon Liambotis.
428   * Add a html plugin, which can be used to write wikis in raw html,
429     if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
430     defaults to not processing .html files, since w/o this plugin they would
431     be copied unsanitised. With this plugin, it will process and html
432     sanitise them, like any other page type.
433   * Rebuilding wrappers is necessary on upgrade to this version.
434   * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
435     will be automatically done on all upgrades.
436   * Don't send pings if the wiki is being rebuilt.
437   * Work around very innefficient behavior in File::Spec::abs2rel. Result
438     is a savings of 2 pointless fork/execs per link calculation, which
439     results in ~25% speedup of ikiwiki building its own doc wiki, and
440     about 35% speedup displaying RecentChanges!
441   * Make RecentChanges use a table and some CSS, should be much more readable.
442     No code changes involved.
443   * Encode & in diffurl in examples, to conform to pedantic rules.
444   * Speed up RecentChanges by another 40% or so with some memoization.
445   * Memoize abs2rel, which is still kinda slow, for another 30% speedup
446     in time to build the doc wiki.
447
448  -- Joey Hess <joeyh@debian.org>  Tue,  4 Jul 2006 12:46:29 -0400
449
450 ikiwiki (1.7) unstable; urgency=low
451
452   * Updated logo from Recai with some kerning and alingment tuning.
453   * Patch from Recai to fix git recentchanges code to work with git 1.4 which
454     changed some output.
455   * Copyright update.
456
457  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 23:33:35 -0400
458
459 ikiwiki (1.6) unstable; urgency=low
460
461   * YA utf-8 patch from Recai, this time to fix previewing a page so that
462     the text in the input box is re-encoded back to utf-8.
463   * -CSD does not affect modules, so readfile() was not using the utf-8 input
464     layer, which led to lots of problems; make it force read files as utf-8.
465     Closes: #373203
466   * Note that as a consequence, this version of ikiwiki will actually try to
467     parse utf8 in source files for the first time, which may expose broken
468     utf8 in wiki sources that was hidden before. Most common will be
469     perl warnings like "utf8 "\xE9" does not map to Unicode"
470   * writefile() likewise needs to use the utf8 output layer.
471   * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
472     there.
473   * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
474     given the readfile fix.
475   * Add utf-8 testcases for readfile and htmlize.
476   * Put back the encode_utf8 in the input to markdown; it's really not utf-8
477     safe.
478   * More utf-8 fixes from Recai, partly to things I broke above:
479     - The serious problem is that writefile() saves the content in undecoded
480       format in CGI, hence all (non-ascii) chars are corrupted permanently.
481     - Comment field in edit page is not decoded and all the non-ascii chars in
482       this field are corrupted as the result.  We should decode it as we do it
483       for the content.
484     - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
485       character in print.
486   * New SVG logo from Recai.
487
488  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 19:18:46 -0400
489
490 ikiwiki (1.5) unstable; urgency=low
491
492   * Add --timeformat config option to allow changing how dates are displayed.
493     Note that as a side effect, dates will now be displayed using the local
494     timezone, not as GMT.
495   * More security review.
496   * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
497     for some handy stuff like:
498     - Using links as a kind of tag; creating blog pages that list all pages
499       containing a given tag/link or not containing some other tag.
500     - Subscribing to mail notifications whenever a change is made to a page
501       that is a backlink of page foo. Ie, "Please notify me of changes in all
502       pages that link to my home page in the wiki"
503     - Locking any pages that are linked to from a particular page, so that
504       lists of locks can be exposed in the wiki.
505   * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
506     when a todo item is done, instead of the previous moving it to a different
507     subdir.
508   * Allow pagetemplate plugins to override *anything* in the template.
509   * Add a meta plugin, which allows specifying various metadata about pages,
510     like license and author. It also allows for inserting html link and meta
511     tags into html, overriding the title, and adding hidden WikiLinks, which
512     can be useful when using link-based globbing for page categorisation.
513   * Remove preprocessor directives from inlined pages.
514   * Allow simple preprocessor directive values to be specified w/o quotes.
515   * Add support for using git instead of subversion as the RCS backend,
516     tremendous thanks to Recai Oktaş for this.
517   * Doc updates for git.
518   * Fix absolute url munging in rss generation to support https, ftp, etc urls
519     not just http urls.
520   * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
521     utf-8 for edit and other fields, and for recentchanges. There may still
522     be utf-8 issues with the preferences page though.
523
524  -- Joey Hess <joeyh@debian.org>  Sun, 11 Jun 2006 19:56:54 -0400
525
526 ikiwiki (1.4) unstable; urgency=low
527
528   * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
529     very strange way of enabling proper XHTML <br /> type tags. Output html
530     should be always valid again now.
531   * The page name and parent links has switched from using a <h1> to a styled
532     <span>, so pages can use <h1> internally instead of needing to use <h2>.
533   * Updated all of ikiwiki's own wiki pages for that.
534   * Add pagetemplate hook, which can be used by plugins that want to mess
535     around with adding new stuff to the page template.
536   * Remove headercontent; the search plugin now adds the search box to the
537     header by registering a pagetemplate hook, and other plugins should do
538     similarly.
539   * Rebuilding on upgrade to this version is recommended.
540   * Add a html validity check to the test suite, using the wdg-html-validator,
541     if available.
542   * Make the html valid when there is nothing in the actions list.
543   * Reordered some function call parameters for consistency.
544   * Enable full utf-8 support for page input and output.
545   * Add a workaround for markdown, which does not work well with utf-8
546     strings.
547   * --getctime had bitrotted (well I only ever used it the once so far..),
548     fix and make it a bit more flexible
549   * rcs_getctime is changed, now rather than needing to loop over all pages,
550     it should just use the rcs to get the ctime of the passed file.
551   * When inlining a page in another one, links from the inlined page are now
552     expanded the same as they are when rendering the inlined page as a
553     standalone page. So rather than being expanded from the POV of the
554     inlining page, they are expanded from the POV of the inlined page.
555
556     For example, a link from blog/foo to "bar" will now link to blog/bar
557     if it exists. Previously this needed to be a link explicitly to
558     "blog/bar"; such links will also continue to work.
559
560     (This was slightly complex to do as the link still has to be constructed
561     relative to the inlining page.)
562   * Make page edit textarea resize to fit browser window.
563   * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
564     do not need a full rebuild, in order to update any basewiki pages.
565
566  -- Joey Hess <joeyh@debian.org>  Sat, 27 May 2006 15:08:49 -0400
567
568 ikiwiki (1.3) unstable; urgency=low
569
570   * Fix the preinst introduced in the last version. Closes: #367458
571
572  -- Joey Hess <joeyh@debian.org>  Tue, 16 May 2006 02:43:02 -0500
573
574 ikiwiki (1.2) unstable; urgency=low
575
576   * Remove dups from the brokenlinks list.
577   * Add libc6-dev to dependencies, needed to build wrappers.
578   * Install wikilist in correct location. Closes: #367371
579
580  -- Joey Hess <joeyh@debian.org>  Mon, 15 May 2006 10:53:49 -0500
581
582 ikiwiki (1.1) unstable; urgency=low
583
584   * Rename inlinepage to depends, so that it can be used to refer to more
585     dependency relationships than just inlining. This will require a rebuild
586     on upgrade to this version.
587   * Move the rss link, put it in the blogpost form if there is one and at the
588     top if not. This is both nicer because easier to find, and it cleans up
589     the code which had used inlinepage as a flag for adding the link later.
590   * Allow the depends GlobList to be built up from multiple sources (such as
591     plugins) during a page render.
592   * Which means that more than one blog is now supported to appear on a
593     single page. (With some limitations, like only the last one getting an
594     rss file.)
595   * Added a plugin system.
596   * Added a pagecount plugin, enabled by default.
597   * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
598   * Fixed/optimised backlinks code, to avoid rebuilding pages to update
599     backlinks when the backlinks hadn't really changed.
600   * Moved inline page support, rss generation etc into the inline plugin,
601     enabled by default.
602   * Added brokenlinks plugin, not enabled by default, but rather handy.
603   * Fix several broken links in the doc wiki.
604   * Smarter behavior when creating a page and a page of the same name (but
605     different location) already exists.
606   * Add an orphans plugin for finding pages that nothing links to.
607   * Removed backlinks page, which it turns out nothing used.
608   * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
609     it, this will allow for adding a unit test suite.
610   * Add unit tests for several core functions, including globlist_match,
611     dirname, basename, bestlink, linkify, pagetitle, titlepage.
612   * Smart globlist merging.
613   * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
614     to pave the way for adding other RCS support. This also changes the
615     setup files, where before they had svn => 1 or svn => 0, now they have
616     rcs => "svn" or rcs => "".
617   * Add a debian/NEWS file with upgrade notes.
618   * Load whatever rcs module is specified, so new ones can be just dropped in
619     as plugins and work. (Well, in theory.)
620   * Add some basic docs about writing RCS modules.
621   * Broke search capability out into a plugin, removed the --hyperestraier
622     switch.
623   * Added smiley plugin, nicely controlled and documented by the smileys page.
624   * Copied in some smileys from Moin Moin.
625   * Allow links of the form [[some page|page]], with whitespace in the link
626     text.
627   * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
628     and --disable-plugin htmlscrubber.
629   * Allow discussion links on pages to be turned off with --no-discussion.
630   * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
631   * Add some new config items to the estseek.conf template, which are needed
632     by hyperestraier 1.2.3.
633
634  -- Joey Hess <joeyh@debian.org>  Fri,  5 May 2006 17:00:41 -0400
635
636 ikiwiki (1.0) unstable; urgency=low
637
638   * First official release.
639
640  -- Joey Hess <joeyh@debian.org>  Tue, 25 Apr 2006 02:08:17 -0400