]> sipb.mit.edu Git - ikiwiki.git/blob - debian/changelog
add
[ikiwiki.git] / debian / changelog
1 ikiwiki (1.9) UNRELEASED; urgency=low
2
3   * Improve display of parentlinks and page title of toplevel index page.
4   * Patch from Faidon to use svn --limit when possible for recentchanges,
5     speeds up recentchanges a lot for wikis with more history.
6   * Patch from Recai to fix utf8 issues in git backend.
7   * Add wikitext markup plugin, which supports ".wiki" pages written in the
8     original wiki syntax, CamelCase links and all.
9   * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
10     support, to edit pages etc without a web server.
11   * Display CGI processing errors if present.
12   * Fix from Faidon for a XML parser issue that breaks utf-8 for
13     RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
14     area, and also way slow.
15
16  -- Joey Hess <joeyh@debian.org>  Tue, 11 Jul 2006 14:37:30 -0400
17
18 ikiwiki (1.8) unstable; urgency=low
19
20   * Fix orphans plugin to not count a link to a nonexistant page as a reason
21     for a page not being an orphan.
22   * Support pinging services such as Technorati using XML-RPC to notify them
23     about changes to rss feeds.
24   * Parse svn log as xml for improved utf8 and security. Note that this makes
25     ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
26   * POSIX::strftime doesn't know about encodings and doesn't return a utf8
27     flagged string even if the locale causes it to generate utf8 output,
28     so make sure to let perl know it should be handled as utf8. Also,
29     the optimised version used for standard time formats won't work if the
30     user has changed locale, so drop it. Thanks, Faidon Liambotis.
31   * Fix re-encoding of the comments field to utf8 if a commit fails
32     due to a conflict. Thanks, Faidon Liambotis.
33   * Let svn know that commits have utf8 commit messages. Thanks, Faidon
34     Liambotis.
35   * Add insane double encode/decode to utf8 around call to markdown.
36     This works around a truely strange bug, which is apparently a bug in
37     perl, #376329. Also added a test case for it.
38   * Improve layout of edit page so formatting help link is always visible w/o
39     getting in the way of the preview.
40   * Centralised all calls to HTML::Template and force all the templates
41     to be read as utf8.
42   * Support pages with utf8 filenames. Patch by Faidon Liambotis.
43   * Introduce add_plugins and disable_plugins config options in setup files.
44     This allows adding or removing plugins w/o overriding the whole list of
45     default plugins, which makes it easier to upgrade when new default plugins
46     are added.
47   * Support htmlize plugins and make mdwn one such plugin, which is enabled by
48     default (of course!). Based on a patch by Faidon Liambotis.
49   * Add a html plugin, which can be used to write wikis in raw html,
50     if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
51     defaults to not processing .html files, since w/o this plugin they would
52     be copied unsanitised. With this plugin, it will process and html
53     sanitise them, like any other page type.
54   * Rebuilding wrappers is necessary on upgrade to this version.
55   * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
56     will be automatically done on all upgrades.
57   * Don't send pings if the wiki is being rebuilt.
58   * Work around very innefficient behavior in File::Spec::abs2rel. Result
59     is a savings of 2 pointless fork/execs per link calculation, which
60     results in ~25% speedup of ikiwiki building its own doc wiki, and
61     about 35% speedup displaying RecentChanges!
62   * Make RecentChanges use a table and some CSS, should be much more readable.
63     No code changes involved.
64   * Encode & in diffurl in examples, to conform to pedantic rules.
65   * Speed up RecentChanges by another 40% or so with some memoization.
66   * Memoize abs2rel, which is still kinda slow, for another 30% speedup
67     in time to build the doc wiki.
68
69  -- Joey Hess <joeyh@debian.org>  Tue,  4 Jul 2006 12:46:29 -0400
70
71 ikiwiki (1.7) unstable; urgency=low
72
73   * Updated logo from Recai with some kerning and alingment tuning.
74   * Patch from Recai to fix git recentchanges code to work with git 1.4 which
75     changed some output.
76   * Copyright update.
77
78  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 23:33:35 -0400
79
80 ikiwiki (1.6) unstable; urgency=low
81
82   * YA utf-8 patch from Recai, this time to fix previewing a page so that
83     the text in the input box is re-encoded back to utf-8.
84   * -CSD does not affect modules, so readfile() was not using the utf-8 input
85     layer, which led to lots of problems; make it force read files as utf-8.
86     Closes: #373203
87   * Note that as a consequence, this version of ikiwiki will actually try to
88     parse utf8 in source files for the first time, which may expose broken
89     utf8 in wiki sources that was hidden before. Most common will be
90     perl warnings like "utf8 "\xE9" does not map to Unicode"
91   * writefile() likewise needs to use the utf8 output layer.
92   * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
93     there.
94   * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
95     given the readfile fix.
96   * Add utf-8 testcases for readfile and htmlize.
97   * Put back the encode_utf8 in the input to markdown; it's really not utf-8
98     safe.
99   * More utf-8 fixes from Recai, partly to things I broke above:
100     - The serious problem is that writefile() saves the content in undecoded
101       format in CGI, hence all (non-ascii) chars are corrupted permanently.
102     - Comment field in edit page is not decoded and all the non-ascii chars in
103       this field are corrupted as the result.  We should decode it as we do it
104       for the content.
105     - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
106       character in print.
107   * New SVG logo from Recai.
108
109  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 19:18:46 -0400
110
111 ikiwiki (1.5) unstable; urgency=low
112
113   * Add --timeformat config option to allow changing how dates are displayed.
114     Note that as a side effect, dates will now be displayed using the local
115     timezone, not as GMT.
116   * More security review.
117   * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
118     for some handy stuff like:
119     - Using links as a kind of tag; creating blog pages that list all pages
120       containing a given tag/link or not containing some other tag.
121     - Subscribing to mail notifications whenever a change is made to a page
122       that is a backlink of page foo. Ie, "Please notify me of changes in all
123       pages that link to my home page in the wiki"
124     - Locking any pages that are linked to from a particular page, so that
125       lists of locks can be exposed in the wiki.
126   * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
127     when a todo item is done, instead of the previous moving it to a different
128     subdir.
129   * Allow pagetemplate plugins to override *anything* in the template.
130   * Add a meta plugin, which allows specifying various metadata about pages,
131     like license and author. It also allows for inserting html link and meta
132     tags into html, overriding the title, and adding hidden WikiLinks, which
133     can be useful when using link-based globbing for page categorisation.
134   * Remove preprocessor directives from inlined pages.
135   * Allow simple preprocessor directive values to be specified w/o quotes.
136   * Add support for using git instead of subversion as the RCS backend,
137     tremendous thanks to Recai Oktaş for this.
138   * Doc updates for git.
139   * Fix absolute url munging in rss generation to support https, ftp, etc urls
140     not just http urls.
141   * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
142     utf-8 for edit and other fields, and for recentchanges. There may still
143     be utf-8 issues with the preferences page though.
144
145  -- Joey Hess <joeyh@debian.org>  Sun, 11 Jun 2006 19:56:54 -0400
146
147 ikiwiki (1.4) unstable; urgency=low
148
149   * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
150     very strange way of enabling proper XHTML <br /> type tags. Output html
151     should be always valid again now.
152   * The page name and parent links has switched from using a <h1> to a styled
153     <span>, so pages can use <h1> internally instead of needing to use <h2>.
154   * Updated all of ikiwiki's own wiki pages for that.
155   * Add pagetemplate hook, which can be used by plugins that want to mess
156     around with adding new stuff to the page template.
157   * Remove headercontent; the search plugin now adds the search box to the
158     header by registering a pagetemplate hook, and other plugins should do
159     similarly.
160   * Rebuilding on upgrade to this version is recommended.
161   * Add a html validity check to the test suite, using the wdg-html-validator,
162     if available.
163   * Make the html valid when there is nothing in the actions list.
164   * Reordered some function call parameters for consistency.
165   * Enable full utf-8 support for page input and output.
166   * Add a workaround for markdown, which does not work well with utf-8
167     strings.
168   * --getctime had bitrotted (well I only ever used it the once so far..),
169     fix and make it a bit more flexible
170   * rcs_getctime is changed, now rather than needing to loop over all pages,
171     it should just use the rcs to get the ctime of the passed file.
172   * When inlining a page in another one, links from the inlined page are now
173     expanded the same as they are when rendering the inlined page as a
174     standalone page. So rather than being expanded from the POV of the
175     inlining page, they are expanded from the POV of the inlined page.
176
177     For example, a link from blog/foo to "bar" will now link to blog/bar
178     if it exists. Previously this needed to be a link explicitly to
179     "blog/bar"; such links will also continue to work.
180
181     (This was slightly complex to do as the link still has to be constructed
182     relative to the inlining page.)
183   * Make page edit textarea resize to fit browser window.
184   * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
185     do not need a full rebuild, in order to update any basewiki pages.
186
187  -- Joey Hess <joeyh@debian.org>  Sat, 27 May 2006 15:08:49 -0400
188
189 ikiwiki (1.3) unstable; urgency=low
190
191   * Fix the preinst introduced in the last version. Closes: #367458
192
193  -- Joey Hess <joeyh@debian.org>  Tue, 16 May 2006 02:43:02 -0500
194
195 ikiwiki (1.2) unstable; urgency=low
196
197   * Remove dups from the brokenlinks list.
198   * Add libc6-dev to dependencies, needed to build wrappers.
199   * Install wikilist in correct location. Closes: #367371
200
201  -- Joey Hess <joeyh@debian.org>  Mon, 15 May 2006 10:53:49 -0500
202
203 ikiwiki (1.1) unstable; urgency=low
204
205   * Rename inlinepage to depends, so that it can be used to refer to more
206     dependency relationships than just inlining. This will require a rebuild
207     on upgrade to this version.
208   * Move the rss link, put it in the blogpost form if there is one and at the
209     top if not. This is both nicer because easier to find, and it cleans up
210     the code which had used inlinepage as a flag for adding the link later.
211   * Allow the depends GlobList to be built up from multiple sources (such as
212     plugins) during a page render.
213   * Which means that more than one blog is now supported to appear on a
214     single page. (With some limitations, like only the last one getting an
215     rss file.)
216   * Added a plugin system.
217   * Added a pagecount plugin, enabled by default.
218   * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
219   * Fixed/optimised backlinks code, to avoid rebuilding pages to update
220     backlinks when the backlinks hadn't really changed.
221   * Moved inline page support, rss generation etc into the inline plugin,
222     enabled by default.
223   * Added brokenlinks plugin, not enabled by default, but rather handy.
224   * Fix several broken links in the doc wiki.
225   * Smarter behavior when creating a page and a page of the same name (but
226     different location) already exists.
227   * Add an orphans plugin for finding pages that nothing links to.
228   * Removed backlinks page, which it turns out nothing used.
229   * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
230     it, this will allow for adding a unit test suite.
231   * Add unit tests for several core functions, including globlist_match,
232     dirname, basename, bestlink, linkify, pagetitle, titlepage.
233   * Smart globlist merging.
234   * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
235     to pave the way for adding other RCS support. This also changes the
236     setup files, where before they had svn => 1 or svn => 0, now they have
237     rcs => "svn" or rcs => "".
238   * Add a debian/NEWS file with upgrade notes.
239   * Load whatever rcs module is specified, so new ones can be just dropped in
240     as plugins and work. (Well, in theory.)
241   * Add some basic docs about writing RCS modules.
242   * Broke search capability out into a plugin, removed the --hyperestraier
243     switch.
244   * Added smiley plugin, nicely controlled and documented by the smileys page.
245   * Copied in some smileys from Moin Moin.
246   * Allow links of the form [[some page|page]], with whitespace in the link
247     text.
248   * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
249     and --disable-plugin htmlscrubber.
250   * Allow discussion links on pages to be turned off with --no-discussion.
251   * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
252   * Add some new config items to the estseek.conf template, which are needed
253     by hyperestraier 1.2.3.
254
255  -- Joey Hess <joeyh@debian.org>  Fri,  5 May 2006 17:00:41 -0400
256
257 ikiwiki (1.0) unstable; urgency=low
258
259   * First official release.
260
261  -- Joey Hess <joeyh@debian.org>  Tue, 25 Apr 2006 02:08:17 -0400