ikiwiki (3.20130711) unstable; urgency=low
[ikiwiki.git] / doc / bugs / Fancy_characters_get_munged_on_page_save.mdwn
1 It doesn't happen on ikiwiki.info but on my site if I enter any of the fancy typography characeters (“,”,…, etc) then when I save the page they are displayed as garbage characters.    I've put an example at the top of [this page](http://adam.shand.net/iki/2007/Test_for_possible_ikiwiki_bug.html?updated).
2
3 Sorry, I know the title is ridiculously vague for a bug but I don't know what the proper name the fancy typography characters are. :-/
4
5 -- [[AdamShand]]
6
7 > The page is fine if I download it and view it locally, or put it on my
8 > laptop's web server. I imagine that the problem is due to your web server
9 > not saying that the encoding of the page is utf8. For apache you could
10 > try setting this: 
11
12 > AddDefaultCharset UTF-8
13
14 > Although I don't need that setting here.. Maybe your apache config has
15 > some problem, because your web server is doing this: --[[Joey]]
16
17         Accept-Ranges: bytes
18         Content-Length: 2135
19         Content-Type: text/html; charset=iso-8859-1
20
21         <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
22          "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
23         <html>
24         <head>
25         <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
26
27 Thanks for that I assumed it would be Perl foo.  I'll look into the web server config.  Though, just thinking some more ... it's weird that it does the correct thing on preview but not on display.  Hrm ... -- Adam.
28
29 **[[FIXED|done]]** - Adding "AddDefaultCharset UTF-8" to my Apache config fixed the problem.  Thanks for the help Joey (especially since it had nothing to do with ikiwiki!).  - Adam.