ikiwiki (3.20130711) unstable; urgency=low
[ikiwiki.git] / doc / bugs / img_plugin_renders___60__img__62___tag_without_src_attribute_post-2.20.mdwn
1 I upgraded from 2.18 to 2.32.3 and my \[[img]] links became `<img>` tags without `src` attributes. Reverting to 2.18 fixes the problem again. I assume this is 2.20, which is the only revision between 2.19 and 2.32.3 to mention img in the changelog.
2
3 > I can't reproduce this. For example, page using the img plugin with a
4 > current version of ikiwiki: <http://kitenet.net/~joey/pics/debconf/7/>
5 > Feel free to mail me a recipe to reproduce it.
6 > --[[Joey]]
7
8 I've done some research and found that `$imgtag` seems properly created in `img.pm`:`preprocess`. Thus, something must be changing it later. Disabling all plugins and leaving only `img` enabled does not fix the problem.
9
10 I added `print STDERR "$imgtag\n";` to `img.pm` after the `my $imgtag='<img src="'.$imgurl.`... statement. This is what happens:
11
12     seamus:~/web/madduck.net/wc> ikiwiki --setup ../ikiwiki.setup --render blog/2008.02.17:the-penny-martin-adventure-phase-2.mdwn | grep img
13     <img src="../img/2008.02.17:chairs_on_the_beach.jpg" alt="Chilling
14       at the beach with chairs" width="301" height="200" class="center" />
15     <img src="../img/2008.02.17:gates_of_haast.jpg" alt="The Gates of Haast" width="487" height="150" class="center" />
16     <img src="../img/2008.02.17:camping_in_cascade_valley.jpg" alt="Camping in Cascade Valley" width="526" height="140" class="center" />
17     <img src="../img/2008.02.17:monteith_keg_urinal.jpg" alt="Keg
18       urinals at Monteith's brewery in Greymouth" width="87" height="150" class="float-right" />
19     <img src="../img/2008.02.17:pancake_rocks_and_nikau_loving.jpg" alt="Pancake rocks
20       at Punakaiki, and Penny loving a Nikau tree" width="582" height="150" class="center" />
21     <img src="../img/2008.02.17:phoenix_foundation_in_concert.jpg" alt="The Phoenix
22       Foundation in concert in Wellington" width="565" height="150" class="center" />
23     <p><a><img alt="Chilling
24     <p><a><img alt="The Gates of Haast" width="487" height="150" class="center" /></a></p>
25     <p><a><img alt="Camping in Cascade Valley" width="526" height="140" class="center" /></a></p>
26     <p><a><img alt="Keg
27     <p><a><img alt="Pancake rocks
28     <p><a><img alt="The Phoenix
29
30 Something is eating the src= attribute.
31
32 I have been unable to reproduce this outside of the `madduck.net` website...
33
34 **Update**: this is the same bug as [[the_colon-in-links_bug|No_link_for_blog_items_when_filename_contains_a_colon]]
35
36 [[!tag done]]