ikiwiki (3.20130711) unstable; urgency=low
[ikiwiki.git] / doc / plugins / theme / discussion.mdwn
1 ### What license do themes need to have for distribution?
2
3 Could someone specify what license the themes need to have to get
4 distributed in ikiwiki or Debian? The current included theme seem to be
5 under the GPLv2. Does the [Creative Commons Attribution 3.0 Unported
6 License](http://creativecommons.org/licenses/by/3.0/) also work. This way a
7 lot of free CSS templates could be included, e. g. from
8 [freecsstemplates.org](http://www.freecsstemplates.org/). --PaulePanter
9
10 > Paule, I'd love it if you did that! The only hard requirement on themes
11 > included in ikiwiki is that they need to be licensed with a [DFSG
12 > compatable license](https://wiki.debian.org/DFSGLicenses). CC-BY-SA 3.0
13 > is DFSG; CC-BY is apparently being accepted by Debian too.
14
15 > As a soft requirement, I may exersise some discretion about themes that
16 > require obtrusive attributions links be included on every page of a
17 > site using the theme. While probably DFSG, that adds a requirement
18 > that ikiwiki itself does not require. --[[Joey]]
19
20 ### Once one has enabled the 'theme' plugin in the setup file, how does one use themes?
21
22 Choose one of the [[themes]] which are bundled with ikiwiki and configure ikiwiki to use it by setting this in your setup file, eg.
23
24         theme => 'blueview',
25
26 -- [[AdamShand]]