Welcome to 2019
[ikiwiki.git] / debian / NEWS
1 ikiwiki (3.20150107) experimental; urgency=medium
2
3   By default, this version of IkiWiki tells mobile browsers that its
4   layout is suitable for small screens. The default layout and the
5   actiontabs, blueview, goldtype and monochrome themes have been adjusted.
6
7   If you have custom CSS that does not work in a small window (a typical
8   phone is 320 to 400 CSS pixels wide), please set the new responsive_layout
9   config option to 0.
10
11  -- Simon McVittie <smcv@debian.org>  Mon, 05 Jan 2015 23:48:42 +0000
12
13 ikiwiki (3.20110122) unstable; urgency=low
14
15   If you have custom CSS that uses "#feedlinks" or "#blogform", you will
16   need to change it to instead use ".feedlinks" and ".blogform"
17
18  -- Joey Hess <joeyh@debian.org>  Fri, 14 Jan 2011 14:34:54 -0400
19
20 ikiwiki (3.20100515) unstable; urgency=low
21
22   There are two significant changes to the page.tmpl template in this version.
23   If you have a locally modified version of that template, you will need to
24   update it at least to contain the following in the HTML <head>:
25
26     <TMPL_IF DYNAMIC>
27     <TMPL_IF FORCEBASEURL><base href="<TMPL_VAR FORCEBASEURL>" /><TMPL_ELSE>
28     <TMPL_IF BASEURL><base href="<TMPL_VAR BASEURL>" /></TMPL_IF>
29     </TMPL_IF>
30     </TMPL_IF>
31
32   Also, the footer should be wrapped in <TMPL_UNLESS DYNAMIC> ... </TMPL_UNLESS>
33   
34   There is a new "comment()" pagespec, that can be used to match a
35   comment on a page. It is recommended it be used instead of the old
36   method of using a pagespec such as "internal(comment_*)" to match
37   things that looked like comments. The old pagespec will now also match
38   comments that are held for moderation; likely not what you want.
39
40   There have also been some changes to the style.css in this version,
41   particularly to support the new openid selector. If you have a modified
42   version, of style.css, updating it (or moving it to local.css) is
43   recommended.
44
45  -- Joey Hess <joeyh@debian.org>  Wed, 05 May 2010 21:47:08 -0400
46
47 ikiwiki (3.20100427) unstable; urgency=low
48
49   This version of ikiwiki has a lot of changes that you need to know about.
50
51   Now you can include customised versions of templates in the source
52   of your wiki. (For example, templates/page.tmpl.) When these templates
53   are changed, ikiwiki will automatically rebuild pages that use them.
54
55   Allowing untrusted users to upload attachments with the ".tmpl"
56   extension is not recommended, as that allows anyone to change
57   a wiki's templates.
58
59   The --getctime switch is renamed to --gettime, and it also gets the 
60   file modification time. And it's a lot faster (when using git). But
61   the really important change is, you don't have to remember to use this
62   switch. Now ikiwiki will do it when it needs to.
63
64   At last, the "tagged()" pagespec only matches tags, not regular wikilinks.
65   If your wiki accidentially relied on the old, buggy behavior, you might
66   need to change its pagespecs to use "link()".
67
68   Many of your wishes have been answered: Now tag pages can automatically be
69   created when new tags are used. This feature is enabled by default if you
70   have configured a tagbase. It can be turned on or off using the
71   tag_autocreate setting.
72
73   These changes may also affect some users:
74
75   * The title_natural sort method (as used by the inline directive, etc)
76     has been moved to the new sortnaturally plugin, which is not enabled
77     by default since it requires the Sort::Naturally perl module.
78
79   * The add_templates option has been removed from the underlay plugin.
80     If you used this option, you can instead use templates/ subdirectories
81     inside underlay directories added by the add_underlays option.
82
83   Due to the above and other changes, all wikis need to be rebuilt on
84   upgrade to this version. If you listed your wiki in /etc/ikiwiki/wikilist
85   this will be done automatically when the Debian package is upgraded. Or
86   use ikiwiki-mass-rebuild to force a rebuild.
87
88  -- Joey Hess <joeyh@debian.org>  Tue, 27 Apr 2010 00:00:00 -0400
89
90 ikiwiki (3.20091017) unstable; urgency=low
91
92   To take advantage of significant performance improvements, all
93   wikis need to be rebuilt on upgrade to this version. If you
94   listed your wiki in /etc/ikiwiki/wikilist this will be done
95   automatically when the Debian package is upgraded. Or use
96   ikiwiki-mass-rebuild to force a rebuild.
97
98  -- Joey Hess <joeyh@debian.org>  Mon, 05 Oct 2009 16:48:59 -0400
99
100 ikiwiki (3.1415926) unstable; urgency=low
101
102   In order to fix a performance bug, all wikis need to be rebuilt on
103   upgrade to this version. If you listed your wiki in
104   /etc/ikiwiki/wikilist this will be done automatically when the
105   Debian package is upgraded. Or use ikiwiki-mass-rebuild to force
106   a rebuild.
107
108  -- Joey Hess <joeyh@debian.org>  Tue, 25 Aug 2009 17:24:43 -0400
109
110 ikiwiki (3.13) unstable; urgency=low
111
112   The `ikiwiki-transition deduplinks` command introduced in the
113   last release was buggy. If you followed the NEWS file instructions
114   and ran it, you should run `ikiwiki -setup` to rebuild your wiki
115   to fix the problem.
116
117  -- Joey Hess <joeyh@debian.org>  Fri, 22 May 2009 13:04:02 -0400
118
119 ikiwiki (3.12) unstable; urgency=low
120
121   You may want to run `ikiwiki-transition deduplinks your.setup`
122   after upgrading to this version of ikiwiki. This command will
123   optimise your wiki's saved state, removing duplicate information
124   that can slow ikiwiki down.
125
126  -- Joey Hess <joeyh@debian.org>  Wed, 06 May 2009 00:25:06 -0400
127
128 ikiwiki (3.01) unstable; urgency=low
129
130   If your wiki uses git, and you have a `diffurl` configured in
131   its setup file, you should be aware that gitweb has stopped
132   supporting the url form commonly used for the `diffurl`.
133
134   You can change your setup to use the newer gitweb url form:
135
136     http://git.example.com/gitweb.cgi?p=wiki.git;a=blobdiff;f=[[file]];h=[[sha1_to]];hp=[[sha1_from]];hb=[[sha1_commit]];hpb=[[sha1_parent]]
137
138   The changes from the old form are the addition of the `hpb` parameter,
139   and the change to the value used for the `hb` parameter.
140
141  -- Joey Hess <joeyh@debian.org>  Mon, 05 Jan 2009 18:18:05 -0500
142
143 ikiwiki (3.00) unstable; urgency=low
144
145   The 3.0 release of ikiwiki changes several defaults and finishes
146   some transitions. You will need to modify your wikis to work with
147   ikiwiki 3.0. A document explaining the process is available
148   in </usr/share/doc/ikiwiki/html/tips/upgrade_to_3.0.html>
149
150  -- Joey Hess <joeyh@debian.org>  Tue, 23 Dec 2008 16:14:18 -0500
151
152 ikiwiki (2.62) unstable; urgency=low
153
154   TexImg standard preamble changed
155
156   The teximg plugin now has a configurable LaTeX preamble.
157   As part of this change the `mchem` LaTeX package has been removed from
158   the default LaTeX preamble as it wasn't included in many TeX installations.
159
160   The previous behaviour can be restored by adding the following to your
161   ikiwiki setup:
162
163         teximg_prefix => '\documentclass{scrartcl}
164                 \usepackage[version=3]{mhchem}
165                 \usepackage{amsmath}
166                 \usepackage{amsfonts}
167                 \usepackage{amssymb}
168                 \pagestyle{empty}
169                 \begin{document}',
170
171   In addition, the rendering mechanism has been changed to use `dvipng` by
172   default, if available.
173
174  -- Joey Hess <joeyh@debian.org>  Sun, 24 Aug 2008 15:00:40 -0400
175
176 ikiwiki (2.60) unstable; urgency=low
177
178   Admin preferences are moving from the web interface to the setup file.
179   There are three new options in the setup file: `locked_pages`, `banned_users`,
180   and `allowed_attachments`. The admin prefs page can still be used, but
181   that's deprecated, and the prefs will be hidden if a value is not already
182   set. If a value is set in the web interface, you're encouraged to move that
183   setting to your setup file now, since version 3.0 will remove the deprecated
184   admin prefs web interface.
185
186   Also, the layout of the setup file has changed in a significant way in this
187   release. Old setup files will continue to work, but new features, like the
188   new websetup interface, require a new format setup file. You can convert
189   old setup files into the new format by running 
190   `ikiwiki-transition setupformat ikiwiki.setup`
191
192  -- Joey Hess <joeyh@debian.org>  Fri, 01 Aug 2008 17:02:14 -0400
193
194 ikiwiki (2.52) unstable; urgency=low
195
196   All wikis need to be rebuilt on upgrade to this version. If you listed your
197   wiki in /etc/ikiwiki/wikilist this will be done automatically when the
198   Debian package is upgraded. Or use ikiwiki-mass-rebuild to force a rebuild.
199
200  -- Joey Hess <joeyh@debian.org>  Sun, 06 Jul 2008 15:10:05 -0400
201
202 ikiwiki (2.49) unstable; urgency=low
203
204   The search plugin no longer uses hyperestraier. Instead, to use it you
205   will now need to install xapian-omega, and the Search::Xapian,
206   HTML::Scrubber, and Digest::SHA1 perl modules. Ie,
207   `apt-get install xapian-omega libsearch-xapian-perl libhtml-scrubber-perl libdigest-sha1-perl`
208
209   Also, wikis that use the search plugin will need to be rebuilt,
210   since the search form has changed. This will not be done automatically,
211   but can be done by running `ikiwiki-mass-upgrade` as root, or
212   running `ikiwiki -setup` on individual setup files.
213
214  -- Joey Hess <joeyh@debian.org>  Wed, 04 Jun 2008 00:29:28 -0400
215
216 ikiwiki (2.48) unstable; urgency=high
217
218   If you allowed password based logins to your wiki, those passwords were
219   stored in cleartext in the userdb. To guard against exposing users'
220   passwords, I recommend you install the Authen::Passphrase perl module, and
221   then run `ikiwiki-transition hashpassword /path/to/srcdir` to replace all
222   existing cleartext passwords with strong (blowfish) hashes.
223
224  -- Joey Hess <joeyh@debian.org>  Thu, 29 May 2008 14:39:34 -0400
225
226 ikiwiki (2.46) unstable; urgency=low
227  
228   There were some significant template changes in ikiwiki 2.42 (and 1.33.5).
229   If you have locally modified versions of the templates, they need to be
230   updated. Most notably, the editpage.tmpl has a new FIELD-SID added to it,
231   without which web editing will fail.
232  
233  -- Joey Hess <joeyh@debian.org>  Tue, 06 May 2008 14:30:14 -0400
234
235 ikiwiki (2.40) unstable; urgency=low
236
237   ikiwiki now has an new syntax for preprocessor directives, using the
238   prefix '!':
239
240   [[!directive ...]]
241
242   This new syntax no longer relies on spaces to distinguish between
243   wikilinks and preprocessor directives.  Thus, wikilinks can use spaces
244   in their link text, and preprocessor directives without arguments (such
245   as "toc") need not use a trailing space.
246
247   To enable the new syntax, set prefix_directives to true in your ikiwiki
248   config.  For backward compatibility with existing wikis,
249   prefix_directives currently defaults to false.  In ikiwiki 3.0,
250   prefix_directives will default to true, and wikis which have not yet
251   converted to the new syntax will need to set prefix_directives to false
252   in their setup files.
253
254   To convert your wiki to the new syntax, ikiwiki provides a new script
255   ikiwiki-transition.
256
257   Even with prefix_directives disabled, ikiwiki now allows an optional '!'
258   prefix on preprocessor directives (but still requires a space).  Thus, a
259   directive which uses a '!' prefix and contains a space will work with
260   ikiwiki 2.40 and newer, regardless of the value of prefix_directives.
261   This allows the underlay to work with all ikiwikis.
262
263  -- Josh Triplett <josh@freedesktop.org>  Sat, 26 Jan 2008 16:26:47 -0800
264
265 ikiwiki (2.30) unstable; urgency=low
266
267   Ever feel that ikiwiki's handling of RecentChanges wasn't truely in the
268   spirit of a wiki compiler? Well, that's changed. The RecentChanges page is
269   now a static page, not a CGI. Users can subscribe to its rss/atom feeds.
270   Custom RecentChanges pages can be easily set up that display only changes
271   to a subset of pages, or only changes by a subset of users.
272   
273   All wikis need to be rebuilt on upgrade to this version. If you listed your
274   wiki in /etc/ikiwiki/wikilist this will be done automatically when the
275   Debian package is upgraded. Or use ikiwiki-mass-rebuild to force a rebuild.
276
277   With this excellent new RecentChanges support, the mail notification system
278   is its age (and known to be variously buggy and underimplemented for
279   various VCSes), and so ikiwiki's support for sending commit mails is REMOVED
280   from this version. If you were subscribed to commit mails, you should be
281   able to accomplish the same thing by subscribing to a RecentChanges feed.
282
283   The "notify" field in setup files is no longer used, and
284   silently ignored. You may want to remove it from your setup file.
285
286  -- Joey Hess <joeyh@debian.org>  Tue, 29 Jan 2008 17:18:31 -0500
287
288 ikiwiki (2.20) unstable; urgency=low
289
290   The template plugin has begin to htmlize the variables passed to templates.
291   This is normally what you want, but to get the old behavior and get at the
292   raw value, you can use `<TMPL_VAR raw_variable>` in a template.
293  
294  -- Joey Hess <joeyh@debian.org>  Sat, 08 Dec 2007 16:04:43 -0500
295
296 ikiwiki (2.16) unstable; urgency=low
297
298   Many of the pages in ikiwiki's basewiki have been moved and renamed in this
299   release, to avoid the basewiki including pages with names like "blog".
300   Redirection pages have been left behind for these moved pages temporarily,
301   and will be removed later.
302
303   If you use the calendar plugin, ikiwiki is now smarter and your nightly
304   cron job to update the wiki doesn't need to rebuild everything. Just pass
305   --refresh to ikiwiki in the cron job and it will update only pages that
306   contain out of date calendars.
307
308  -- Joey Hess <joeyh@debian.org>  Sat, 08 Dec 2007 16:04:43 -0500
309
310 ikiwiki (2.14) unstable; urgency=low
311
312   This version of ikiwiki is more picky about symlinks in the path leading
313   to the srcdir, and will refuse to use a srcdir specified by such a path.
314   This was necessary to avoid some potential exploits, but could potentially
315   break (semi-)working wikis. If your wiki has a srcdir path containing a
316   symlink, you should change it to use a path that does not.
317
318  -- Joey Hess <joeyh@debian.org>  Mon, 26 Nov 2007 14:57:57 -0500
319
320 ikiwiki (2.9) unstable; urgency=low
321
322   Since ikiwiki 2.0 was released, some limitiations have been added to what
323   ikiwiki considers a WikiLink. In short, if there are any spaces in between
324   the brackets, ikiwiki no longer considers it to be a WikiLink. If your wiki
325   contains things meant to be WikiLinks that contain spaces, you will need to
326   fix them, by replacing the spaces with underscores.
327   
328   WikiLink have always been documented to not contain spaces, but bugs in
329   ikiwiki made it treat some text with spaces as WikiLinks. Most of these
330   bugs were fixed in version 2.2, and a final bug was fixed in this 2.9
331   release. These fixes are necessary to avoid ambiguity between
332   WikiLinks and PreProcessorDirectives. Apologies for any inconvenience
333   these bugs (and their fixes) may have caused.
334
335  -- Joey Hess <joeyh@debian.org>  Sat, 29 Sep 2007 14:37:18 -0400
336
337 ikiwiki (2.6) unstable; urgency=low
338
339   In this version the rst plugin allows raw html to be embedded in rst files.
340   As long as the htmlscrubber is enabled, this should be safe. If you are
341   using the rst plugin without the htmlscrubber in a publically writable wiki,
342   you should turn on the htmlscrubber.
343
344  -- Joey Hess <joeyh@debian.org>  Sun, 29 Jul 2007 18:37:22 -0400
345
346 ikiwiki (2.5) unstable; urgency=low
347
348   Due to some config changes in this version, wrappers need to be rebuilt on
349   upgrade. If you listed your wiki in /etc/ikiwiki/wikilist this will be
350   one automatically when the Debian package is upgraded.
351
352  -- Joey Hess <joeyh@debian.org>  Sun, 29 Jul 2007 17:54:40 -0400
353
354 ikiwiki (2.1) unstable; urgency=low
355
356   Some wikis need to be rebuilt on upgrade to this version, due to changes to
357   page templates and the style sheet. If you listed your wiki in
358   /etc/ikiwiki/wikilist this will be done automatically when the Debian
359   package is upgraded. Or use ikiwiki-mass-rebuild to force a rebuild.
360
361  -- Joey Hess <joeyh@debian.org>  Thu, 26 Apr 2007 15:50:36 -0400
362
363 ikiwiki (2.00) unstable; urgency=low
364
365   With the 2.0 release of ikiwiki, some major changes have been made to the
366   default configuration:
367
368   * The 'usedirs' setting is enabled by default. This *will* break all URLs
369     to wikis that did not have 'usedirs' turned on before, unless you follow
370     the procedure described at <http://ikiwiki.info/tips/switching_to_usedirs>,
371     or edit your setup file to turn usedirs off:
372        usedirs => 0,
373
374   * OpenID logins are now enabled by default, if the Net::OpenID::Consumer
375     perl module is available. Password logins are also still enabled
376     by default. If you like, you can turn either OpenID or password logins
377     off via the 'disable_plugins' setting.
378
379  -- Joey Hess <joeyh@debian.org>  Sun, 29 Apr 2007 19:00:43 -0400
380
381 ikiwiki (1.51) unstable; urgency=low
382
383   Some wikis need to be rebuilt on upgrade to this version, due to changes to
384   page layout and the style sheet. If you listed your wiki in
385   /etc/ikiwiki/wikilist this will be done automatically when the Debian
386   package is upgraded. Or use ikiwiki-mass-rebuild to force a rebuild.
387
388  -- Joey Hess <joeyh@debian.org>  Thu, 26 Apr 2007 15:50:36 -0400
389
390 ikiwiki (1.50) unstable; urgency=low
391
392   Permalinks and guids in rss and atom feeds for wikis using the usedirs
393   options will change in this release. If you have already enabled usedirs,
394   you may need to take steps to avoid flooding aggregators.
395
396  -- Joey Hess <joeyh@debian.org>  Sat, 14 Apr 2007 16:08:46 -0400
397
398 ikiwiki (1.49) unstable; urgency=low
399
400   Third-party plugins that use htmlpage() or abs2rel() to generate links
401   may need changes to support the new "usedirs" option.
402
403  -- Joey Hess <joeyh@debian.org>  Sun, 01 Apr 2007 16:20:09 -0400
404
405 ikiwiki (1.47) unstable; urgency=low
406  
407   Due to a security fix, wikis that have the htmlscrubber enabled can no
408   longer use the meta plugin to insert html link and meta tags.
409
410   Some special case methods have been added for safely including stylesheets,
411   and for doing openid delegation. See the meta plugin docs for details.
412  
413  -- Joey Hess <joeyh@debian.org>  Wed, 21 Mar 2007 14:18:40 -0400
414
415 ikiwiki (1.45) unstable; urgency=low
416
417   Wikis need to be rebuilt on upgrade to this version. If you listed your wiki
418   in /etc/ikiwiki/wikilist this will be done automatically when the Debian
419   package is upgraded. Or use ikiwiki-mass-rebuild to force a rebuild.
420
421  -- Joey Hess <joeyh@debian.org>  Wed,  7 Mar 2007 23:02:52 -0500
422
423 ikiwiki (1.44) unstable; urgency=low
424
425   The htmllink() function has changed slightly and plugins that use it may
426   need to change how they call it. This function's first three parameters
427   are unchanged, but additional options are now passed using named
428   parameters. If you used htmllink with more than 3 parameters, you will
429   need to change it. The plugin interface version has been increased to 1.02
430   to reflect this change.
431
432  -- Joey Hess <joeyh@debian.org>  Mon, 19 Feb 2007 21:10:12 -0500
433
434 ikiwiki (1.42) unstable; urgency=low
435
436   The anonok setting in config files has been removed. To enable
437   httpauth support on your wiki, you should now enable the anonok plugin,
438   instead.
439
440   Third-party plugins that use pagespec_match() should be updated to pass
441   the new third parameter (from) to that function. This is needed for the
442   new relative glob matching to work.
443
444  -- Joey Hess <joeyh@debian.org>  Thu,  1 Feb 2007 16:57:59 -0500
445
446 ikiwiki (1.34) unstable; urgency=low
447
448   The httpauth setting in config files has been removed. To enable
449   httpauth support on your wiki, you should now enable the httpauth plugin,
450   instead.
451
452   This release includes OpenID support that is enabled through the openid
453   plugin. I recommend turning this on to make it easier for users to sign
454   in to your wiki.
455
456  -- Joey Hess <joeyh@debian.org>  Sun, 19 Nov 2006 20:53:05 -0500
457
458 ikiwiki (1.32) unstable; urgency=low
459
460   There is a change to the plugin interface in this version. Any plugins that
461   modify data in %links should pass scan => 1 when registering the hook that
462   does so.
463
464  -- Joey Hess <joeyh@debian.org>  Sat, 28 Oct 2006 00:13:12 -0400
465
466 ikiwiki (1.29) unstable; urgency=low
467
468   Wikis need to be rebuilt on upgrade to this version. If you listed your wiki
469   in /etc/ikiwiki/wikilist this will be done automatically when the Debian
470   package is upgraded. Or use ikiwiki-mass-rebuild to force a rebuild.
471
472   There is a change to the plugin interface in this version. Plugins that use
473   %renderedfiles will need to be updated, as the hash's values are now arrays
474   of rendered files. Plugins that cause a page to render additional files
475   should use the new will_render function to register the files.
476
477  -- Joey Hess <joeyh@debian.org>  Sun,  8 Oct 2006 17:27:56 -0400
478
479 ikiwiki (1.22) unstable; urgency=low
480   
481   Due to some changes in the CSS, wikis should be rebuilt on upgrade to this
482   version. If you listed your wiki in /etc/ikiwiki/wikilist this will be done
483   automatically when the Debian package is upgraded. Or use ikiwiki-mass-rebuild
484   to force a rebuild.
485
486   If you have modified versions of ikiwiki's html templates, you will need
487   to update your templates to link to the stylesheet file using
488   "<TMPL_VAR BASEURL>style.css" instead of the old method which used
489   STYLEURL.
490
491   There have also been some changes to the plugin interface:
492   Any plugins that use santize, htmlize, or format hooks will need to be
493   updated for this version of ikiwiki since these hooks have been changed
494   to use named parameters.
495
496  -- Joey Hess <joeyh@debian.org>  Tue, 22 Aug 2006 15:33:12 -0400
497
498 ikiwiki (1.13) unstable; urgency=low
499
500   The GlobList format which was used for specifiying sets of pages, has been
501   replaced with a new, more expressive PageSpec format. While GlobLists will
502   continue to work, that format is deprecated, and you are encouraged to use
503   PageSpecs from now on, and also to change any GlobLists in your wiki to
504   PageSpecs. See the new PageSpec page for details.
505   
506   You will need to rebuild your wiki when upgrading to this version. If you
507   listed your wiki in /etc/ikiwiki/wikilist this will be done automatically
508   when the Debian package is upgraded. Or use ikiiki-mass-rebuild to force a
509   rebuild.
510
511  -- Joey Hess <joeyh@debian.org>  Tue,  1 Aug 2006 18:29:51 -0400
512
513 ikiwiki (1.11) unstable; urgency=low
514
515   Some changes to tags in this release, due to a new tag plugin. If you have
516   been using the meta plugin to tag pages, you'll want to enable the tag
517   plugin too, and change things like this:
518
519   [[meta link="foobar"]]
520
521   To this:
522
523   [[tag foobar]]
524
525   The new tags will appear at page footers, and are also easier to type.
526
527   There have also been some changes to the plugin interface, particularly the
528   interface of pagetemplate hooks has changed. See the changelog for details.
529
530  -- Joey Hess <joeyh@debian.org>  Thu, 27 Jul 2006 17:03:09 -0400
531
532 ikiwiki (1.8) unstable; urgency=low
533
534   If your wiki is configured with a setup file, you should modify it to
535   stop setting the "plugin" list directly, and instead add or remove plugins
536   via the add_plugins and disable_plugins lines. For example, if you had:
537
538         plugin => [qw{inline smiley search}],
539
540   Change it to these lines, which disables the default htmlscrubber plugin
541   and adds the two additional plugins:
542
543         add_plugins => [qw{smiley search}],
544         disable_plugins => [qw{htmlscrubber}],
545
546   Making this change makes your ikiwiki setup file more future-proof since
547   new default plugins will be automatically used.
548   
549   You will need to rebuild your ikiwiki wrappers when upgrading to this
550   version. If you listed your wiki in /etc/ikiwiki/wikilist this will be
551   done automatically when the Debian package is upgraded. Or use
552   ikiiki-mass-rebuild --refresh to force a refresh.
553
554  -- Joey Hess <joeyh@debian.org>  Mon,  3 Jul 2006 16:59:29 -0400
555
556 ikiwiki (1.1) unstable; urgency=low
557
558   There have been several configuration changes in this release of ikiwiki:
559
560   The --svn and --no-svn switches are removed, instead you should use
561    --rcs=svn or --no-rcs. ikiwiki setup files that set svn => 1 should
562   be changed to set rcs => "svn"; if your setup file sets svn => 0
563   then change it to use rcs => "" to disable svn.
564
565   The --hyperestraier switch is gone too. To enable searching, turn on the
566   search plugin, by passing --plugin=search or through the plugin setting in
567   the setup file.
568
569   The --sanitize and --no-sanitize switches are also gone, replaced with the
570   htmlscrubber plugin. This plugin is enabled by default, to disable it,
571   use --disable-plugin=htmlscrubber, or modify the plugin setting in the
572   setup file.
573
574   Discussion pages are enabled by default, but if your wiki is configured
575   with a setup file, you need to edit it to keep them enabled on upgrade
576   to this version. Add a line reading:
577   discussion => 1,
578
579   You will need to rebuild your wiki when upgrading to this version.
580   If you listed your wiki in /etc/ikiwiki/wikilist this will be done
581   automatically when the Debian package is upgraded. Or use
582   ikiiki-mass-rebuild to force a rebuild.
583
584  -- Joey Hess <joeyh@debian.org>  Tue,  2 May 2006 14:13:59 -0400