Documentation for parameter `template`?
[ikiwiki.git] / debian / NEWS
1 ikiwiki (3.13) unstable; urgency=low
2
3   The `ikiwiki-transition deduplinks` command introduced in the
4   last release was buggy. If you followed the NEWS file instructions
5   and ran it, you should run `ikiwiki -setup` to rebuild your wiki
6   to fix the problem.
7
8  -- Joey Hess <joeyh@debian.org>  Fri, 22 May 2009 13:04:02 -0400
9
10 ikiwiki (3.12) unstable; urgency=low
11
12   You may want to run `ikiwiki-transition deduplinks your.setup`
13   after upgrading to this version of ikiwiki. This command will
14   optimise your wiki's saved state, removing duplicate information
15   that can slow ikiwiki down.
16
17  -- Joey Hess <joeyh@debian.org>  Wed, 06 May 2009 00:25:06 -0400
18
19 ikiwiki (3.01) unstable; urgency=low
20
21   If your wiki uses git, and you have a `diffurl` configured in
22   its setup file, you should be aware that gitweb has stopped
23   supporting the url form commonly used for the `diffurl`.
24
25   You can change your setup to use the newer gitweb url form:
26
27     http://git.example.com/gitweb.cgi?p=wiki.git;a=blobdiff;f=[[file]];h=[[sha1_to]];hp=[[sha1_from]];hb=[[sha1_commit]];hpb=[[sha1_parent]]
28
29   The changes from the old form are the addition of the `hpb` parameter,
30   and the change to the value used for the `hb` parameter.
31
32  -- Joey Hess <joeyh@debian.org>  Mon, 05 Jan 2009 18:18:05 -0500
33
34 ikiwiki (3.00) unstable; urgency=low
35
36   The 3.0 release of ikiwiki changes several defaults and finishes
37   some transitions. You will need to modify your wikis to work with
38   ikiwiki 3.0. A document explaining the process is available
39   in </usr/share/doc/ikiwiki/html/tips/upgrade_to_3.0.html>
40
41  -- Joey Hess <joeyh@debian.org>  Tue, 23 Dec 2008 16:14:18 -0500
42
43 ikiwiki (2.62) unstable; urgency=low
44
45   TexImg standard preamble changed
46
47   The teximg plugin now has a configurable LaTeX preamble.
48   As part of this change the `mchem` LaTeX package has been removed from
49   the default LaTeX preamble as it wasn't included in many TeX installations.
50
51   The previous behaviour can be restored by adding the following to your
52   ikiwiki setup:
53
54         teximg_prefix => '\documentclass{scrartcl}
55                 \usepackage[version=3]{mhchem}
56                 \usepackage{amsmath}
57                 \usepackage{amsfonts}
58                 \usepackage{amssymb}
59                 \pagestyle{empty}
60                 \begin{document}',
61
62   In addition, the rendering mechanism has been changed to use `dvipng` by
63   default, if available.
64
65  -- Joey Hess <joeyh@debian.org>  Sun, 24 Aug 2008 15:00:40 -0400
66
67 ikiwiki (2.60) unstable; urgency=low
68
69   Admin preferences are moving from the web interface to the setup file.
70   There are three new options in the setup file: `locked_pages`, `banned_users`,
71   and `allowed_attachments`. The admin prefs page can still be used, but
72   that's deprecated, and the prefs will be hidden if a value is not already
73   set. If a value is set in the web interface, you're encouraged to move that
74   setting to your setup file now, since version 3.0 will remove the deprecated
75   admin prefs web interface.
76
77   Also, the layout of the setup file has changed in a significant way in this
78   release. Old setup files will continue to work, but new features, like the
79   new websetup interface, require a new format setup file. You can convert
80   old setup files into the new format by running 
81   `ikiwiki-transition setupformat ikiwiki.setup`
82
83  -- Joey Hess <joeyh@debian.org>  Fri, 01 Aug 2008 17:02:14 -0400
84
85 ikiwiki (2.52) unstable; urgency=low
86
87   All wikis need to be rebuilt on upgrade to this version. If you listed your
88   wiki in /etc/ikiwiki/wikilist this will be done automatically when the
89   Debian package is upgraded. Or use ikiwiki-mass-rebuild to force a rebuild.
90
91  -- Joey Hess <joeyh@debian.org>  Sun, 06 Jul 2008 15:10:05 -0400
92
93 ikiwiki (2.49) unstable; urgency=low
94
95   The search plugin no longer uses hyperestraier. Instead, to use it you
96   will now need to install xapian-omega, and the Search::Xapian,
97   HTML::Scrubber, and Digest::SHA1 perl modules. Ie,
98   `apt-get install xapian-omega libsearch-xapian-perl libhtml-scrubber-perl libdigest-sha1-perl`
99
100   Also, wikis that use the search plugin will need to be rebuilt,
101   since the search form has changed. This will not be done automatically,
102   but can be done by running `ikiwiki-mass-upgrade` as root, or
103   running `ikiwiki -setup` on individual setup files.
104
105  -- Joey Hess <joeyh@debian.org>  Wed, 04 Jun 2008 00:29:28 -0400
106
107 ikiwiki (2.48) unstable; urgency=high
108
109   If you allowed password based logins to your wiki, those passwords were
110   stored in cleartext in the userdb. To guard against exposing users'
111   passwords, I recommend you install the Authen::Passphrase perl module, and
112   then run `ikiwiki-transition hashpassword /path/to/srcdir` to replace all
113   existing cleartext passwords with strong (blowfish) hashes.
114
115  -- Joey Hess <joeyh@debian.org>  Thu, 29 May 2008 14:39:34 -0400
116
117 ikiwiki (2.46) unstable; urgency=low
118  
119   There were some significant template changes in ikiwiki 2.42 (and 1.33.5).
120   If you have locally modified versions of the templates, they need to be
121   updated. Most notably, the editpage.tmpl has a new FIELD-SID added to it,
122   without which web editing will fail.
123  
124  -- Joey Hess <joeyh@debian.org>  Tue, 06 May 2008 14:30:14 -0400
125
126 ikiwiki (2.40) unstable; urgency=low
127
128   ikiwiki now has an new syntax for preprocessor directives, using the
129   prefix '!':
130
131   [[!directive ...]]
132
133   This new syntax no longer relies on spaces to distinguish between
134   wikilinks and preprocessor directives.  Thus, wikilinks can use spaces
135   in their link text, and preprocessor directives without arguments (such
136   as "toc") need not use a trailing space.
137
138   To enable the new syntax, set prefix_directives to true in your ikiwiki
139   config.  For backward compatibility with existing wikis,
140   prefix_directives currently defaults to false.  In ikiwiki 3.0,
141   prefix_directives will default to true, and wikis which have not yet
142   converted to the new syntax will need to set prefix_directives to false
143   in their setup files.
144
145   To convert your wiki to the new syntax, ikiwiki provides a new script
146   ikiwiki-transition.
147
148   Even with prefix_directives disabled, ikiwiki now allows an optional '!'
149   prefix on preprocessor directives (but still requires a space).  Thus, a
150   directive which uses a '!' prefix and contains a space will work with
151   ikiwiki 2.40 and newer, regardless of the value of prefix_directives.
152   This allows the underlay to work with all ikiwikis.
153
154  -- Josh Triplett <josh@freedesktop.org>  Sat, 26 Jan 2008 16:26:47 -0800
155
156 ikiwiki (2.30) unstable; urgency=low
157
158   Ever feel that ikiwiki's handling of RecentChanges wasn't truely in the
159   spirit of a wiki compiler? Well, that's changed. The RecentChanges page is
160   now a static page, not a CGI. Users can subscribe to its rss/atom feeds.
161   Custom RecentChanges pages can be easily set up that display only changes
162   to a subset of pages, or only changes by a subset of users.
163   
164   All wikis need to be rebuilt on upgrade to this version. If you listed your
165   wiki in /etc/ikiwiki/wikilist this will be done automatically when the
166   Debian package is upgraded. Or use ikiwiki-mass-rebuild to force a rebuild.
167
168   With this excellent new RecentChanges support, the mail notification system
169   is its age (and known to be variously buggy and underimplemented for
170   various VCSes), and so ikiwiki's support for sending commit mails is REMOVED
171   from this version. If you were subscribed to commit mails, you should be
172   able to accomplish the same thing by subscribing to a RecentChanges feed.
173
174   The "notify" field in setup files is no longer used, and
175   silently ignored. You may want to remove it from your setup file.
176
177  -- Joey Hess <joeyh@debian.org>  Tue, 29 Jan 2008 17:18:31 -0500
178
179 ikiwiki (2.20) unstable; urgency=low
180
181   The template plugin has begin to htmlize the variables passed to templates.
182   This is normally what you want, but to get the old behavior and get at the
183   raw value, you can use `<TMPL_VAR raw_variable>` in a template.
184  
185  -- Joey Hess <joeyh@debian.org>  Sat, 08 Dec 2007 16:04:43 -0500
186
187 ikiwiki (2.16) unstable; urgency=low
188
189   Many of the pages in ikiwiki's basewiki have been moved and renamed in this
190   release, to avoid the basewiki including pages with names like "blog".
191   Redirection pages have been left behind for these moved pages temporarily,
192   and will be removed later.
193
194   If you use the calendar plugin, ikiwiki is now smarter and your nightly
195   cron job to update the wiki doesn't need to rebuild everything. Just pass
196   --refresh to ikiwiki in the cron job and it will update only pages that
197   contain out of date calendars.
198
199  -- Joey Hess <joeyh@debian.org>  Sat, 08 Dec 2007 16:04:43 -0500
200
201 ikiwiki (2.14) unstable; urgency=low
202
203   This version of ikiwiki is more picky about symlinks in the path leading
204   to the srcdir, and will refuse to use a srcdir specified by such a path.
205   This was necessary to avoid some potential exploits, but could potentially
206   break (semi-)working wikis. If your wiki has a srcdir path containing a
207   symlink, you should change it to use a path that does not.
208
209  -- Joey Hess <joeyh@debian.org>  Mon, 26 Nov 2007 14:57:57 -0500
210
211 ikiwiki (2.9) unstable; urgency=low
212
213   Since ikiwiki 2.0 was released, some limitiations have been added to what
214   ikiwiki considers a WikiLink. In short, if there are any spaces in between
215   the brackets, ikiwiki no longer considers it to be a WikiLink. If your wiki
216   contains things meant to be WikiLinks that contain spaces, you will need to
217   fix them, by replacing the spaces with underscores.
218   
219   WikiLink have always been documented to not contain spaces, but bugs in
220   ikiwiki made it treat some text with spaces as WikiLinks. Most of these
221   bugs were fixed in version 2.2, and a final bug was fixed in this 2.9
222   release. These fixes are necessary to avoid ambiguity between
223   WikiLinks and PreProcessorDirectives. Apologies for any inconvenience
224   these bugs (and their fixes) may have caused.
225
226  -- Joey Hess <joeyh@debian.org>  Sat, 29 Sep 2007 14:37:18 -0400
227
228 ikiwiki (2.6) unstable; urgency=low
229
230   In this version the rst plugin allows raw html to be embedded in rst files.
231   As long as the htmlscrubber is enabled, this should be safe. If you are
232   using the rst plugin without the htmlscrubber in a publically writable wiki,
233   you should turn on the htmlscrubber.
234
235  -- Joey Hess <joeyh@debian.org>  Sun, 29 Jul 2007 18:37:22 -0400
236
237 ikiwiki (2.5) unstable; urgency=low
238
239   Due to some config changes in this version, wrappers need to be rebuilt on
240   upgrade. If you listed your wiki in /etc/ikiwiki/wikilist this will be
241   one automatically when the Debian package is upgraded.
242
243  -- Joey Hess <joeyh@debian.org>  Sun, 29 Jul 2007 17:54:40 -0400
244
245 ikiwiki (2.1) unstable; urgency=low
246
247   Some wikis need to be rebuilt on upgrade to this version, due to changes to
248   page templates and the style sheet. If you listed your wiki in
249   /etc/ikiwiki/wikilist this will be done automatically when the Debian
250   package is upgraded. Or use ikiwiki-mass-rebuild to force a rebuild.
251
252  -- Joey Hess <joeyh@debian.org>  Thu, 26 Apr 2007 15:50:36 -0400
253
254 ikiwiki (2.00) unstable; urgency=low
255
256   With the 2.0 release of ikiwiki, some major changes have been made to the
257   default configuration:
258
259   * The 'usedirs' setting is enabled by default. This *will* break all URLs
260     to wikis that did not have 'usedirs' turned on before, unless you follow
261     the procedure described at <http://ikiwiki.info/tips/switching_to_usedirs>,
262     or edit your setup file to turn usedirs off:
263        usedirs => 0,
264
265   * OpenID logins are now enabled by default, if the Net::OpenID::Consumer
266     perl module is available. Password logins are also still enabled
267     by default. If you like, you can turn either OpenID or password logins
268     off via the 'disable_plugins' setting.
269
270  -- Joey Hess <joeyh@debian.org>  Sun, 29 Apr 2007 19:00:43 -0400
271
272 ikiwiki (1.51) unstable; urgency=low
273
274   Some wikis need to be rebuilt on upgrade to this version, due to changes to
275   page layout and the style sheet. If you listed your wiki in
276   /etc/ikiwiki/wikilist this will be done automatically when the Debian
277   package is upgraded. Or use ikiwiki-mass-rebuild to force a rebuild.
278
279  -- Joey Hess <joeyh@debian.org>  Thu, 26 Apr 2007 15:50:36 -0400
280
281 ikiwiki (1.50) unstable; urgency=low
282
283   Permalinks and guids in rss and atom feeds for wikis using the usedirs
284   options will change in this release. If you have already enabled usedirs,
285   you may need to take steps to avoid flooding aggregators.
286
287  -- Joey Hess <joeyh@debian.org>  Sat, 14 Apr 2007 16:08:46 -0400
288
289 ikiwiki (1.49) unstable; urgency=low
290
291   Third-party plugins that use htmlpage() or abs2rel() to generate links
292   may need changes to support the new "usedirs" option.
293
294  -- Joey Hess <joeyh@debian.org>  Sun, 01 Apr 2007 16:20:09 -0400
295
296 ikiwiki (1.47) unstable; urgency=low
297  
298   Due to a security fix, wikis that have the htmlscrubber enabled can no
299   longer use the meta plugin to insert html link and meta tags.
300
301   Some special case methods have been added for safely including stylesheets,
302   and for doing openid delegation. See the meta plugin docs for details.
303  
304  -- Joey Hess <joeyh@debian.org>  Wed, 21 Mar 2007 14:18:40 -0400
305
306 ikiwiki (1.45) unstable; urgency=low
307
308   Wikis need to be rebuilt on upgrade to this version. If you listed your wiki
309   in /etc/ikiwiki/wikilist this will be done automatically when the Debian
310   package is upgraded. Or use ikiwiki-mass-rebuild to force a rebuild.
311
312  -- Joey Hess <joeyh@debian.org>  Wed,  7 Mar 2007 23:02:52 -0500
313
314 ikiwiki (1.44) unstable; urgency=low
315
316   The htmllink() function has changed slightly and plugins that use it may
317   need to change how they call it. This function's first three parameters
318   are unchanged, but additional options are now passed using named
319   parameters. If you used htmllink with more than 3 parameters, you will
320   need to change it. The plugin interface version has been increased to 1.02
321   to reflect this change.
322
323  -- Joey Hess <joeyh@debian.org>  Mon, 19 Feb 2007 21:10:12 -0500
324
325 ikiwiki (1.42) unstable; urgency=low
326
327   The anonok setting in config files has been removed. To enable
328   httpauth support on your wiki, you should now enable the anonok plugin,
329   instead.
330
331   Third-party plugins that use pagespec_match() should be updated to pass
332   the new third parameter (from) to that function. This is needed for the
333   new relative glob matching to work.
334
335  -- Joey Hess <joeyh@debian.org>  Thu,  1 Feb 2007 16:57:59 -0500
336
337 ikiwiki (1.34) unstable; urgency=low
338
339   The httpauth setting in config files has been removed. To enable
340   httpauth support on your wiki, you should now enable the httpauth plugin,
341   instead.
342
343   This release includes OpenID support that is enabled through the openid
344   plugin. I recommend turning this on to make it easier for users to sign
345   in to your wiki.
346
347  -- Joey Hess <joeyh@debian.org>  Sun, 19 Nov 2006 20:53:05 -0500
348
349 ikiwiki (1.32) unstable; urgency=low
350
351   There is a change to the plugin interface in this version. Any plugins that
352   modify data in %links should pass scan => 1 when registering the hook that
353   does so.
354
355  -- Joey Hess <joeyh@debian.org>  Sat, 28 Oct 2006 00:13:12 -0400
356
357 ikiwiki (1.29) unstable; urgency=low
358
359   Wikis need to be rebuilt on upgrade to this version. If you listed your wiki
360   in /etc/ikiwiki/wikilist this will be done automatically when the Debian
361   package is upgraded. Or use ikiwiki-mass-rebuild to force a rebuild.
362
363   There is a change to the plugin interface in this version. Plugins that use
364   %renderedfiles will need to be updated, as the hash's values are now arrays
365   of rendered files. Plugins that cause a page to render additional files
366   should use the new will_render function to register the files.
367
368  -- Joey Hess <joeyh@debian.org>  Sun,  8 Oct 2006 17:27:56 -0400
369
370 ikiwiki (1.22) unstable; urgency=low
371   
372   Due to some changes in the CSS, wikis should be rebuilt on upgrade to this
373   version. If you listed your wiki in /etc/ikiwiki/wikilist this will be done
374   automatically when the Debian package is upgraded. Or use ikiwiki-mass-rebuild
375   to force a rebuild.
376
377   If you have modified versions of ikiwiki's html templates, you will need
378   to update your templates to link to the stylesheet file using
379   "<TMPL_VAR BASEURL>style.css" instead of the old method which used
380   STYLEURL.
381
382   There have also been some changes to the plugin interface:
383   Any plugins that use santize, htmlize, or format hooks will need to be
384   updated for this version of ikiwiki since these hooks have been changed
385   to use named parameters.
386
387  -- Joey Hess <joeyh@debian.org>  Tue, 22 Aug 2006 15:33:12 -0400
388
389 ikiwiki (1.13) unstable; urgency=low
390
391   The GlobList format which was used for specifiying sets of pages, has been
392   replaced with a new, more expressive PageSpec format. While GlobLists will
393   continue to work, that format is deprecated, and you are encouraged to use
394   PageSpecs from now on, and also to change any GlobLists in your wiki to
395   PageSpecs. See the new PageSpec page for details.
396   
397   You will need to rebuild your wiki when upgrading to this version. If you
398   listed your wiki in /etc/ikiwiki/wikilist this will be done automatically
399   when the Debian package is upgraded. Or use ikiiki-mass-rebuild to force a
400   rebuild.
401
402  -- Joey Hess <joeyh@debian.org>  Tue,  1 Aug 2006 18:29:51 -0400
403
404 ikiwiki (1.11) unstable; urgency=low
405
406   Some changes to tags in this release, due to a new tag plugin. If you have
407   been using the meta plugin to tag pages, you'll want to enable the tag
408   plugin too, and change things like this:
409
410   [[meta link="foobar"]]
411
412   To this:
413
414   [[tag foobar]]
415
416   The new tags will appear at page footers, and are also easier to type.
417
418   There have also been some changes to the plugin interface, particularly the
419   interface of pagetemplate hooks has changed. See the changelog for details.
420
421  -- Joey Hess <joeyh@debian.org>  Thu, 27 Jul 2006 17:03:09 -0400
422
423 ikiwiki (1.8) unstable; urgency=low
424
425   If your wiki is configured with a setup file, you should modify it to
426   stop setting the "plugin" list directly, and instead add or remove plugins
427   via the add_plugins and disable_plugins lines. For example, if you had:
428
429         plugin => [qw{inline smiley search}],
430
431   Change it to these lines, which disables the default htmlscrubber plugin
432   and adds the two additional plugins:
433
434         add_plugins => [qw{smiley search}],
435         disable_plugins => [qw{htmlscrubber}],
436
437   Making this change makes your ikiwiki setup file more future-proof since
438   new default plugins will be automatically used.
439   
440   You will need to rebuild your ikiwiki wrappers when upgrading to this
441   version. If you listed your wiki in /etc/ikiwiki/wikilist this will be
442   done automatically when the Debian package is upgraded. Or use
443   ikiiki-mass-rebuild --refresh to force a refresh.
444
445  -- Joey Hess <joeyh@debian.org>  Mon,  3 Jul 2006 16:59:29 -0400
446
447 ikiwiki (1.1) unstable; urgency=low
448
449   There have been several configuration changes in this release of ikiwiki:
450
451   The --svn and --no-svn switches are removed, instead you should use
452    --rcs=svn or --no-rcs. ikiwiki setup files that set svn => 1 should
453   be changed to set rcs => "svn"; if your setup file sets svn => 0
454   then change it to use rcs => "" to disable svn.
455
456   The --hyperestraier switch is gone too. To enable searching, turn on the
457   search plugin, by passing --plugin=search or through the plugin setting in
458   the setup file.
459
460   The --sanitize and --no-sanitize switches are also gone, replaced with the
461   htmlscrubber plugin. This plugin is enabled by default, to disable it,
462   use --disable-plugin=htmlscrubber, or modify the plugin setting in the
463   setup file.
464
465   Discussion pages are enabled by default, but if your wiki is configured
466   with a setup file, you need to edit it to keep them enabled on upgrade
467   to this version. Add a line reading:
468   discussion => 1,
469
470   You will need to rebuild your wiki when upgrading to this version.
471   If you listed your wiki in /etc/ikiwiki/wikilist this will be done
472   automatically when the Debian package is upgraded. Or use
473   ikiiki-mass-rebuild to force a rebuild.
474
475  -- Joey Hess <joeyh@debian.org>  Tue,  2 May 2006 14:13:59 -0400