link fix
[ikiwiki.git] / debian / NEWS
1 ikiwiki (3.20100406) unstable; urgency=low
2
3   This version of ikiwiki has a lot of changes that you need to know about.
4
5   The --getctime switch is renamed to --gettimes, and it also gets the 
6   file modification time. And it's a lot faster (when using git). But
7   the really important change is, you don't have to remember to use this
8   switch. Now ikiwiki will do it when it needs to.
9
10   Starting from this version, the `tagged()` pagespec only matches tags,
11   not regular wikilinks. If your wiki accidentially relied on the old,
12   buggy behavior, you might need to change pagespecs to use `link()`.
13
14   The title_natural sort method (as used by the inline directive, etc)
15   have been moved to the new sortnaturally plugin, which is not enabled
16   by default since it requires the Sort::Naturally perl module.
17
18   Due to the above and other changes, all wikis need to be rebuilt on
19   upgrade to this version. If you listed your wiki in /etc/ikiwiki/wikilist
20   this will be done automatically when the Debian package is upgraded. Or
21   use ikiwiki-mass-rebuild to force a rebuild.
22
23  -- Joey Hess <joeyh@debian.org>  Wed, 21 Apr 2010 20:31:29 -0400
24
25 ikiwiki (3.20091017) unstable; urgency=low
26
27   To take advantage of significant performance improvements, all
28   wikis need to be rebuilt on upgrade to this version. If you
29   listed your wiki in /etc/ikiwiki/wikilist this will be done
30   automatically when the Debian package is upgraded. Or use
31   ikiwiki-mass-rebuild to force a rebuild.
32
33  -- Joey Hess <joeyh@debian.org>  Mon, 05 Oct 2009 16:48:59 -0400
34
35 ikiwiki (3.1415926) unstable; urgency=low
36
37   In order to fix a performance bug, all wikis need to be rebuilt on
38   upgrade to this version. If you listed your wiki in
39   /etc/ikiwiki/wikilist this will be done automatically when the
40   Debian package is upgraded. Or use ikiwiki-mass-rebuild to force
41   a rebuild.
42
43  -- Joey Hess <joeyh@debian.org>  Tue, 25 Aug 2009 17:24:43 -0400
44
45 ikiwiki (3.13) unstable; urgency=low
46
47   The `ikiwiki-transition deduplinks` command introduced in the
48   last release was buggy. If you followed the NEWS file instructions
49   and ran it, you should run `ikiwiki -setup` to rebuild your wiki
50   to fix the problem.
51
52  -- Joey Hess <joeyh@debian.org>  Fri, 22 May 2009 13:04:02 -0400
53
54 ikiwiki (3.12) unstable; urgency=low
55
56   You may want to run `ikiwiki-transition deduplinks your.setup`
57   after upgrading to this version of ikiwiki. This command will
58   optimise your wiki's saved state, removing duplicate information
59   that can slow ikiwiki down.
60
61  -- Joey Hess <joeyh@debian.org>  Wed, 06 May 2009 00:25:06 -0400
62
63 ikiwiki (3.01) unstable; urgency=low
64
65   If your wiki uses git, and you have a `diffurl` configured in
66   its setup file, you should be aware that gitweb has stopped
67   supporting the url form commonly used for the `diffurl`.
68
69   You can change your setup to use the newer gitweb url form:
70
71     http://git.example.com/gitweb.cgi?p=wiki.git;a=blobdiff;f=[[file]];h=[[sha1_to]];hp=[[sha1_from]];hb=[[sha1_commit]];hpb=[[sha1_parent]]
72
73   The changes from the old form are the addition of the `hpb` parameter,
74   and the change to the value used for the `hb` parameter.
75
76  -- Joey Hess <joeyh@debian.org>  Mon, 05 Jan 2009 18:18:05 -0500
77
78 ikiwiki (3.00) unstable; urgency=low
79
80   The 3.0 release of ikiwiki changes several defaults and finishes
81   some transitions. You will need to modify your wikis to work with
82   ikiwiki 3.0. A document explaining the process is available
83   in </usr/share/doc/ikiwiki/html/tips/upgrade_to_3.0.html>
84
85  -- Joey Hess <joeyh@debian.org>  Tue, 23 Dec 2008 16:14:18 -0500
86
87 ikiwiki (2.62) unstable; urgency=low
88
89   TexImg standard preamble changed
90
91   The teximg plugin now has a configurable LaTeX preamble.
92   As part of this change the `mchem` LaTeX package has been removed from
93   the default LaTeX preamble as it wasn't included in many TeX installations.
94
95   The previous behaviour can be restored by adding the following to your
96   ikiwiki setup:
97
98         teximg_prefix => '\documentclass{scrartcl}
99                 \usepackage[version=3]{mhchem}
100                 \usepackage{amsmath}
101                 \usepackage{amsfonts}
102                 \usepackage{amssymb}
103                 \pagestyle{empty}
104                 \begin{document}',
105
106   In addition, the rendering mechanism has been changed to use `dvipng` by
107   default, if available.
108
109  -- Joey Hess <joeyh@debian.org>  Sun, 24 Aug 2008 15:00:40 -0400
110
111 ikiwiki (2.60) unstable; urgency=low
112
113   Admin preferences are moving from the web interface to the setup file.
114   There are three new options in the setup file: `locked_pages`, `banned_users`,
115   and `allowed_attachments`. The admin prefs page can still be used, but
116   that's deprecated, and the prefs will be hidden if a value is not already
117   set. If a value is set in the web interface, you're encouraged to move that
118   setting to your setup file now, since version 3.0 will remove the deprecated
119   admin prefs web interface.
120
121   Also, the layout of the setup file has changed in a significant way in this
122   release. Old setup files will continue to work, but new features, like the
123   new websetup interface, require a new format setup file. You can convert
124   old setup files into the new format by running 
125   `ikiwiki-transition setupformat ikiwiki.setup`
126
127  -- Joey Hess <joeyh@debian.org>  Fri, 01 Aug 2008 17:02:14 -0400
128
129 ikiwiki (2.52) unstable; urgency=low
130
131   All wikis need to be rebuilt on upgrade to this version. If you listed your
132   wiki in /etc/ikiwiki/wikilist this will be done automatically when the
133   Debian package is upgraded. Or use ikiwiki-mass-rebuild to force a rebuild.
134
135  -- Joey Hess <joeyh@debian.org>  Sun, 06 Jul 2008 15:10:05 -0400
136
137 ikiwiki (2.49) unstable; urgency=low
138
139   The search plugin no longer uses hyperestraier. Instead, to use it you
140   will now need to install xapian-omega, and the Search::Xapian,
141   HTML::Scrubber, and Digest::SHA1 perl modules. Ie,
142   `apt-get install xapian-omega libsearch-xapian-perl libhtml-scrubber-perl libdigest-sha1-perl`
143
144   Also, wikis that use the search plugin will need to be rebuilt,
145   since the search form has changed. This will not be done automatically,
146   but can be done by running `ikiwiki-mass-upgrade` as root, or
147   running `ikiwiki -setup` on individual setup files.
148
149  -- Joey Hess <joeyh@debian.org>  Wed, 04 Jun 2008 00:29:28 -0400
150
151 ikiwiki (2.48) unstable; urgency=high
152
153   If you allowed password based logins to your wiki, those passwords were
154   stored in cleartext in the userdb. To guard against exposing users'
155   passwords, I recommend you install the Authen::Passphrase perl module, and
156   then run `ikiwiki-transition hashpassword /path/to/srcdir` to replace all
157   existing cleartext passwords with strong (blowfish) hashes.
158
159  -- Joey Hess <joeyh@debian.org>  Thu, 29 May 2008 14:39:34 -0400
160
161 ikiwiki (2.46) unstable; urgency=low
162  
163   There were some significant template changes in ikiwiki 2.42 (and 1.33.5).
164   If you have locally modified versions of the templates, they need to be
165   updated. Most notably, the editpage.tmpl has a new FIELD-SID added to it,
166   without which web editing will fail.
167  
168  -- Joey Hess <joeyh@debian.org>  Tue, 06 May 2008 14:30:14 -0400
169
170 ikiwiki (2.40) unstable; urgency=low
171
172   ikiwiki now has an new syntax for preprocessor directives, using the
173   prefix '!':
174
175   [[!directive ...]]
176
177   This new syntax no longer relies on spaces to distinguish between
178   wikilinks and preprocessor directives.  Thus, wikilinks can use spaces
179   in their link text, and preprocessor directives without arguments (such
180   as "toc") need not use a trailing space.
181
182   To enable the new syntax, set prefix_directives to true in your ikiwiki
183   config.  For backward compatibility with existing wikis,
184   prefix_directives currently defaults to false.  In ikiwiki 3.0,
185   prefix_directives will default to true, and wikis which have not yet
186   converted to the new syntax will need to set prefix_directives to false
187   in their setup files.
188
189   To convert your wiki to the new syntax, ikiwiki provides a new script
190   ikiwiki-transition.
191
192   Even with prefix_directives disabled, ikiwiki now allows an optional '!'
193   prefix on preprocessor directives (but still requires a space).  Thus, a
194   directive which uses a '!' prefix and contains a space will work with
195   ikiwiki 2.40 and newer, regardless of the value of prefix_directives.
196   This allows the underlay to work with all ikiwikis.
197
198  -- Josh Triplett <josh@freedesktop.org>  Sat, 26 Jan 2008 16:26:47 -0800
199
200 ikiwiki (2.30) unstable; urgency=low
201
202   Ever feel that ikiwiki's handling of RecentChanges wasn't truely in the
203   spirit of a wiki compiler? Well, that's changed. The RecentChanges page is
204   now a static page, not a CGI. Users can subscribe to its rss/atom feeds.
205   Custom RecentChanges pages can be easily set up that display only changes
206   to a subset of pages, or only changes by a subset of users.
207   
208   All wikis need to be rebuilt on upgrade to this version. If you listed your
209   wiki in /etc/ikiwiki/wikilist this will be done automatically when the
210   Debian package is upgraded. Or use ikiwiki-mass-rebuild to force a rebuild.
211
212   With this excellent new RecentChanges support, the mail notification system
213   is its age (and known to be variously buggy and underimplemented for
214   various VCSes), and so ikiwiki's support for sending commit mails is REMOVED
215   from this version. If you were subscribed to commit mails, you should be
216   able to accomplish the same thing by subscribing to a RecentChanges feed.
217
218   The "notify" field in setup files is no longer used, and
219   silently ignored. You may want to remove it from your setup file.
220
221  -- Joey Hess <joeyh@debian.org>  Tue, 29 Jan 2008 17:18:31 -0500
222
223 ikiwiki (2.20) unstable; urgency=low
224
225   The template plugin has begin to htmlize the variables passed to templates.
226   This is normally what you want, but to get the old behavior and get at the
227   raw value, you can use `<TMPL_VAR raw_variable>` in a template.
228  
229  -- Joey Hess <joeyh@debian.org>  Sat, 08 Dec 2007 16:04:43 -0500
230
231 ikiwiki (2.16) unstable; urgency=low
232
233   Many of the pages in ikiwiki's basewiki have been moved and renamed in this
234   release, to avoid the basewiki including pages with names like "blog".
235   Redirection pages have been left behind for these moved pages temporarily,
236   and will be removed later.
237
238   If you use the calendar plugin, ikiwiki is now smarter and your nightly
239   cron job to update the wiki doesn't need to rebuild everything. Just pass
240   --refresh to ikiwiki in the cron job and it will update only pages that
241   contain out of date calendars.
242
243  -- Joey Hess <joeyh@debian.org>  Sat, 08 Dec 2007 16:04:43 -0500
244
245 ikiwiki (2.14) unstable; urgency=low
246
247   This version of ikiwiki is more picky about symlinks in the path leading
248   to the srcdir, and will refuse to use a srcdir specified by such a path.
249   This was necessary to avoid some potential exploits, but could potentially
250   break (semi-)working wikis. If your wiki has a srcdir path containing a
251   symlink, you should change it to use a path that does not.
252
253  -- Joey Hess <joeyh@debian.org>  Mon, 26 Nov 2007 14:57:57 -0500
254
255 ikiwiki (2.9) unstable; urgency=low
256
257   Since ikiwiki 2.0 was released, some limitiations have been added to what
258   ikiwiki considers a WikiLink. In short, if there are any spaces in between
259   the brackets, ikiwiki no longer considers it to be a WikiLink. If your wiki
260   contains things meant to be WikiLinks that contain spaces, you will need to
261   fix them, by replacing the spaces with underscores.
262   
263   WikiLink have always been documented to not contain spaces, but bugs in
264   ikiwiki made it treat some text with spaces as WikiLinks. Most of these
265   bugs were fixed in version 2.2, and a final bug was fixed in this 2.9
266   release. These fixes are necessary to avoid ambiguity between
267   WikiLinks and PreProcessorDirectives. Apologies for any inconvenience
268   these bugs (and their fixes) may have caused.
269
270  -- Joey Hess <joeyh@debian.org>  Sat, 29 Sep 2007 14:37:18 -0400
271
272 ikiwiki (2.6) unstable; urgency=low
273
274   In this version the rst plugin allows raw html to be embedded in rst files.
275   As long as the htmlscrubber is enabled, this should be safe. If you are
276   using the rst plugin without the htmlscrubber in a publically writable wiki,
277   you should turn on the htmlscrubber.
278
279  -- Joey Hess <joeyh@debian.org>  Sun, 29 Jul 2007 18:37:22 -0400
280
281 ikiwiki (2.5) unstable; urgency=low
282
283   Due to some config changes in this version, wrappers need to be rebuilt on
284   upgrade. If you listed your wiki in /etc/ikiwiki/wikilist this will be
285   one automatically when the Debian package is upgraded.
286
287  -- Joey Hess <joeyh@debian.org>  Sun, 29 Jul 2007 17:54:40 -0400
288
289 ikiwiki (2.1) unstable; urgency=low
290
291   Some wikis need to be rebuilt on upgrade to this version, due to changes to
292   page templates and the style sheet. If you listed your wiki in
293   /etc/ikiwiki/wikilist this will be done automatically when the Debian
294   package is upgraded. Or use ikiwiki-mass-rebuild to force a rebuild.
295
296  -- Joey Hess <joeyh@debian.org>  Thu, 26 Apr 2007 15:50:36 -0400
297
298 ikiwiki (2.00) unstable; urgency=low
299
300   With the 2.0 release of ikiwiki, some major changes have been made to the
301   default configuration:
302
303   * The 'usedirs' setting is enabled by default. This *will* break all URLs
304     to wikis that did not have 'usedirs' turned on before, unless you follow
305     the procedure described at <http://ikiwiki.info/tips/switching_to_usedirs>,
306     or edit your setup file to turn usedirs off:
307        usedirs => 0,
308
309   * OpenID logins are now enabled by default, if the Net::OpenID::Consumer
310     perl module is available. Password logins are also still enabled
311     by default. If you like, you can turn either OpenID or password logins
312     off via the 'disable_plugins' setting.
313
314  -- Joey Hess <joeyh@debian.org>  Sun, 29 Apr 2007 19:00:43 -0400
315
316 ikiwiki (1.51) unstable; urgency=low
317
318   Some wikis need to be rebuilt on upgrade to this version, due to changes to
319   page layout and the style sheet. If you listed your wiki in
320   /etc/ikiwiki/wikilist this will be done automatically when the Debian
321   package is upgraded. Or use ikiwiki-mass-rebuild to force a rebuild.
322
323  -- Joey Hess <joeyh@debian.org>  Thu, 26 Apr 2007 15:50:36 -0400
324
325 ikiwiki (1.50) unstable; urgency=low
326
327   Permalinks and guids in rss and atom feeds for wikis using the usedirs
328   options will change in this release. If you have already enabled usedirs,
329   you may need to take steps to avoid flooding aggregators.
330
331  -- Joey Hess <joeyh@debian.org>  Sat, 14 Apr 2007 16:08:46 -0400
332
333 ikiwiki (1.49) unstable; urgency=low
334
335   Third-party plugins that use htmlpage() or abs2rel() to generate links
336   may need changes to support the new "usedirs" option.
337
338  -- Joey Hess <joeyh@debian.org>  Sun, 01 Apr 2007 16:20:09 -0400
339
340 ikiwiki (1.47) unstable; urgency=low
341  
342   Due to a security fix, wikis that have the htmlscrubber enabled can no
343   longer use the meta plugin to insert html link and meta tags.
344
345   Some special case methods have been added for safely including stylesheets,
346   and for doing openid delegation. See the meta plugin docs for details.
347  
348  -- Joey Hess <joeyh@debian.org>  Wed, 21 Mar 2007 14:18:40 -0400
349
350 ikiwiki (1.45) unstable; urgency=low
351
352   Wikis need to be rebuilt on upgrade to this version. If you listed your wiki
353   in /etc/ikiwiki/wikilist this will be done automatically when the Debian
354   package is upgraded. Or use ikiwiki-mass-rebuild to force a rebuild.
355
356  -- Joey Hess <joeyh@debian.org>  Wed,  7 Mar 2007 23:02:52 -0500
357
358 ikiwiki (1.44) unstable; urgency=low
359
360   The htmllink() function has changed slightly and plugins that use it may
361   need to change how they call it. This function's first three parameters
362   are unchanged, but additional options are now passed using named
363   parameters. If you used htmllink with more than 3 parameters, you will
364   need to change it. The plugin interface version has been increased to 1.02
365   to reflect this change.
366
367  -- Joey Hess <joeyh@debian.org>  Mon, 19 Feb 2007 21:10:12 -0500
368
369 ikiwiki (1.42) unstable; urgency=low
370
371   The anonok setting in config files has been removed. To enable
372   httpauth support on your wiki, you should now enable the anonok plugin,
373   instead.
374
375   Third-party plugins that use pagespec_match() should be updated to pass
376   the new third parameter (from) to that function. This is needed for the
377   new relative glob matching to work.
378
379  -- Joey Hess <joeyh@debian.org>  Thu,  1 Feb 2007 16:57:59 -0500
380
381 ikiwiki (1.34) unstable; urgency=low
382
383   The httpauth setting in config files has been removed. To enable
384   httpauth support on your wiki, you should now enable the httpauth plugin,
385   instead.
386
387   This release includes OpenID support that is enabled through the openid
388   plugin. I recommend turning this on to make it easier for users to sign
389   in to your wiki.
390
391  -- Joey Hess <joeyh@debian.org>  Sun, 19 Nov 2006 20:53:05 -0500
392
393 ikiwiki (1.32) unstable; urgency=low
394
395   There is a change to the plugin interface in this version. Any plugins that
396   modify data in %links should pass scan => 1 when registering the hook that
397   does so.
398
399  -- Joey Hess <joeyh@debian.org>  Sat, 28 Oct 2006 00:13:12 -0400
400
401 ikiwiki (1.29) unstable; urgency=low
402
403   Wikis need to be rebuilt on upgrade to this version. If you listed your wiki
404   in /etc/ikiwiki/wikilist this will be done automatically when the Debian
405   package is upgraded. Or use ikiwiki-mass-rebuild to force a rebuild.
406
407   There is a change to the plugin interface in this version. Plugins that use
408   %renderedfiles will need to be updated, as the hash's values are now arrays
409   of rendered files. Plugins that cause a page to render additional files
410   should use the new will_render function to register the files.
411
412  -- Joey Hess <joeyh@debian.org>  Sun,  8 Oct 2006 17:27:56 -0400
413
414 ikiwiki (1.22) unstable; urgency=low
415   
416   Due to some changes in the CSS, wikis should be rebuilt on upgrade to this
417   version. If you listed your wiki in /etc/ikiwiki/wikilist this will be done
418   automatically when the Debian package is upgraded. Or use ikiwiki-mass-rebuild
419   to force a rebuild.
420
421   If you have modified versions of ikiwiki's html templates, you will need
422   to update your templates to link to the stylesheet file using
423   "<TMPL_VAR BASEURL>style.css" instead of the old method which used
424   STYLEURL.
425
426   There have also been some changes to the plugin interface:
427   Any plugins that use santize, htmlize, or format hooks will need to be
428   updated for this version of ikiwiki since these hooks have been changed
429   to use named parameters.
430
431  -- Joey Hess <joeyh@debian.org>  Tue, 22 Aug 2006 15:33:12 -0400
432
433 ikiwiki (1.13) unstable; urgency=low
434
435   The GlobList format which was used for specifiying sets of pages, has been
436   replaced with a new, more expressive PageSpec format. While GlobLists will
437   continue to work, that format is deprecated, and you are encouraged to use
438   PageSpecs from now on, and also to change any GlobLists in your wiki to
439   PageSpecs. See the new PageSpec page for details.
440   
441   You will need to rebuild your wiki when upgrading to this version. If you
442   listed your wiki in /etc/ikiwiki/wikilist this will be done automatically
443   when the Debian package is upgraded. Or use ikiiki-mass-rebuild to force a
444   rebuild.
445
446  -- Joey Hess <joeyh@debian.org>  Tue,  1 Aug 2006 18:29:51 -0400
447
448 ikiwiki (1.11) unstable; urgency=low
449
450   Some changes to tags in this release, due to a new tag plugin. If you have
451   been using the meta plugin to tag pages, you'll want to enable the tag
452   plugin too, and change things like this:
453
454   [[meta link="foobar"]]
455
456   To this:
457
458   [[tag foobar]]
459
460   The new tags will appear at page footers, and are also easier to type.
461
462   There have also been some changes to the plugin interface, particularly the
463   interface of pagetemplate hooks has changed. See the changelog for details.
464
465  -- Joey Hess <joeyh@debian.org>  Thu, 27 Jul 2006 17:03:09 -0400
466
467 ikiwiki (1.8) unstable; urgency=low
468
469   If your wiki is configured with a setup file, you should modify it to
470   stop setting the "plugin" list directly, and instead add or remove plugins
471   via the add_plugins and disable_plugins lines. For example, if you had:
472
473         plugin => [qw{inline smiley search}],
474
475   Change it to these lines, which disables the default htmlscrubber plugin
476   and adds the two additional plugins:
477
478         add_plugins => [qw{smiley search}],
479         disable_plugins => [qw{htmlscrubber}],
480
481   Making this change makes your ikiwiki setup file more future-proof since
482   new default plugins will be automatically used.
483   
484   You will need to rebuild your ikiwiki wrappers when upgrading to this
485   version. If you listed your wiki in /etc/ikiwiki/wikilist this will be
486   done automatically when the Debian package is upgraded. Or use
487   ikiiki-mass-rebuild --refresh to force a refresh.
488
489  -- Joey Hess <joeyh@debian.org>  Mon,  3 Jul 2006 16:59:29 -0400
490
491 ikiwiki (1.1) unstable; urgency=low
492
493   There have been several configuration changes in this release of ikiwiki:
494
495   The --svn and --no-svn switches are removed, instead you should use
496    --rcs=svn or --no-rcs. ikiwiki setup files that set svn => 1 should
497   be changed to set rcs => "svn"; if your setup file sets svn => 0
498   then change it to use rcs => "" to disable svn.
499
500   The --hyperestraier switch is gone too. To enable searching, turn on the
501   search plugin, by passing --plugin=search or through the plugin setting in
502   the setup file.
503
504   The --sanitize and --no-sanitize switches are also gone, replaced with the
505   htmlscrubber plugin. This plugin is enabled by default, to disable it,
506   use --disable-plugin=htmlscrubber, or modify the plugin setting in the
507   setup file.
508
509   Discussion pages are enabled by default, but if your wiki is configured
510   with a setup file, you need to edit it to keep them enabled on upgrade
511   to this version. Add a line reading:
512   discussion => 1,
513
514   You will need to rebuild your wiki when upgrading to this version.
515   If you listed your wiki in /etc/ikiwiki/wikilist this will be done
516   automatically when the Debian package is upgraded. Or use
517   ikiiki-mass-rebuild to force a rebuild.
518
519  -- Joey Hess <joeyh@debian.org>  Tue,  2 May 2006 14:13:59 -0400