update instructions to work with new debian apache packages
authorJoey Hess <joey@kitenet.net>
Tue, 4 Jun 2013 21:16:49 +0000 (17:16 -0400)
committerJoey Hess <joey@kitenet.net>
Tue, 4 Jun 2013 21:19:27 +0000 (17:19 -0400)
doc/tips/dot_cgi.mdwn

index dc88d9595ae838a31d2f00ec9e233e07949631f7..9067fbea57c6f3e77cdb2b72d00403a12d096f2c 100644 (file)
@@ -15,7 +15,10 @@ configuration changes should work anywhere.
 
 ## apache 2
 
 
 ## apache 2
 
-* Edit /etc/apache2/apache2.conf and add a line like this:
+* Make sure the cgi module is loaded. (Ie, `a2enmod cgi`)
+
+* Edit /etc/apache2/apache2.conf (or /etc/apache2/mods-available/mime.conf)
+  and add a line like this:
 
        AddHandler cgi-script .cgi
 
 
        AddHandler cgi-script .cgi
 
@@ -26,8 +29,6 @@ configuration changes should work anywhere.
   Or, if you've put it in a `~/public_html`, edit
   `/etc/apache2/mods-available/userdir.conf`.
 
   Or, if you've put it in a `~/public_html`, edit
   `/etc/apache2/mods-available/userdir.conf`.
 
-  You may also want to install some dependencies to enable CGI in apache2 setup as: `libcgi-formbuilder-perl` and `libcgi-session-perl`.
-
 * If your wiki is in `~/public_html` and does not appear when you enter the URL given by the installer, check that you have 
   the userdir mod enabled (there should be simlinks to userdir.load and userdir.conf in /etc/apache2/modes-enabled).  If not,
   run `a2enmod userdir` and reload apache2.
 * If your wiki is in `~/public_html` and does not appear when you enter the URL given by the installer, check that you have 
   the userdir mod enabled (there should be simlinks to userdir.load and userdir.conf in /etc/apache2/modes-enabled).  If not,
   run `a2enmod userdir` and reload apache2.